Jump to content

Archived

This topic is now archived and is closed to further replies.

stchong

problem with using "load data local infile" in MyS

Recommended Posts

my mysql is 4.0.12.

I am using mysqld-max-nt...

I have check for information in mysql\'s web site,but still can not solve the problem! still can not use load data local infile...

every time it shows me the same error message:

ERROR 1148: The used command is not allowed with this MySQL version

 

I have tried two ways

1. in the command line of mysql

mysql --local-infile=1 -u root -p

I also tried.....

mysql --local-infile=0 -u root -p

but all can not

 

2. modify the my.ini

set-variable=local-infile=1

I also tried

set-variable=local-infile=0

but all still can not

 

so what\'t the problem????

Help me, please...

Tahnks a lot

Share this post


Link to post
Share on other sites

I have found that you need to include information about the delimiters if you are working in a Windows environment. I use TABs to delinieate fields and then I use the following command:

 

load data infile \'d:/test.txt\' 

into table test 

fields terminated by \'t\'

lines terminated by \'rn\';

 

Notice the need to specify the Carriage Return, New Line combination. Without it this doesn\'twork.

 

Alternatively have you tried

load data local infile ... 

?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.