Jump to content

Archived

This topic is now archived and is closed to further replies.

unclemid

PHP Will not load properly, it keeps trying to download instead of display.

Recommended Posts

SORRY FOR THE DOUBLE POSTING. I COULDNT FIGURE OUT HOW TO CHANGE THE TITLE IN THE OTHER ONE SO PLEASE DISCARD THE OTHER ONE..........

Ok heres the problem. Ive got apache and php on my computer, all configured and everything and all of the sudden now when i try to open php files locally on my computer they wont display and they try to download. PLEASE HELP this is urgent and im at a real crunch for time. Thanks.

Share this post


Link to post
Share on other sites
[!--quoteo(post=354781:date=Mar 13 2006, 10:36 PM:name=charlesdayhoff)--][div class=\'quotetop\']QUOTE(charlesdayhoff @ Mar 13 2006, 10:36 PM) [snapback]354781[/snapback][/div][div class=\'quotemain\'][!--quotec--]
SORRY FOR THE DOUBLE POSTING. I COULDNT FIGURE OUT HOW TO CHANGE THE TITLE IN THE OTHER ONE SO PLEASE DISCARD THE OTHER ONE..........

Ok heres the problem. Ive got apache and php on my computer, all configured and everything and all of the sudden now when i try to open php files locally on my computer they wont display and they try to download. PLEASE HELP this is urgent and im at a real crunch for time. Thanks.
[/quote]


So, how do you know you have it installed properly?

one way to ensure that everything is working fine is by going to [a href=\"http://localhost\" target=\"_blank\"]http://localhost[/a] and it should show you either the package installation or the root folder of your installation. It sounds to me like something went wrong with your installation.

Another thing you can do is re-boot. Maybe that will clear things out.

Share this post


Link to post
Share on other sites
No need to reboot, just restart apache every time you make a change to .conf files..

make sure you've AddType and AddModule to httpd.conf!

Share this post


Link to post
Share on other sites
That depends on if you are using CGI PHP or not, but the question is has it ever worked and have you made any recent changes.

Share this post


Link to post
Share on other sites
[!--quoteo(post=354806:date=Mar 14 2006, 08:43 AM:name=txmedic03)--][div class=\'quotetop\']QUOTE(txmedic03 @ Mar 14 2006, 08:43 AM) [snapback]354806[/snapback][/div][div class=\'quotemain\'][!--quotec--]
That depends on if you are using CGI PHP or not, but the question is has it ever worked and have you made any recent changes.
[/quote]

Just click on the apache symbol bottom rigth hand side within the apache dialog box on the bottom what does it say , you should see the apache version and php version also database version.

If the information exists then all is set correctly then its your php.ini file setup.


If you dont see any inforamtion on the apache dialpg box, then the php is not loadded properly then reinstall the php package or goto www.hotscripts.com and look up apache and install a pre perpered package with all the included pakages example. apach,php,mysql,cgi.etc.etc

good luck.




Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.