Jump to content


Photo

Easy PHP


  • Please log in to reply
20 replies to this topic

#1 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 16 March 2006 - 10:56 PM

Hello,
I currently have Easy php. I designated the directory root in apache as C:/WWW
and i currently get no error in my error log except:
[Thu Mar 16 16:40:53 2006] [error] PHP Notice: Undefined offset: 2 in c:\\www\\footer.php on line 15
[Thu Mar 16 16:40:53 2006] [error] [client 127.0.0.1] File does not exist: c:/www/idlerpg.png
[Thu Mar 16 16:41:19 2006] [error] [client 127.0.0.1] File does not exist: c:/www/idlerpg.png
[Thu Mar 16 16:41:53 2006] [error] [client 127.0.0.1] File does not exist: c:/www/idlerpg.png
[Thu Mar 16 16:41:53 2006] [error] [client 127.0.0.1] File does not exist: c:/www/idlerpg.png

But I believe these are not seriuose problems. Anyways, when i log into: LocalHost
The website comes up perfectly the way it should (Except for a few pictures)
However my friends cannot log into my website. The website is: mirpg.no-ip.info
My ip is: 74.33.105.147

Window's Firewall is off. I think i might need some help with my router being configured.

Thanks for the help
Shizzell

#2 redarrow

redarrow
  • Members
  • PipPipPip
  • Advanced Member
  • 7,308 posts
  • Locationlondon

Posted 16 March 2006 - 11:06 PM

do a nslookup in the dos prompt and post your ip the one you provided is wrong or meachine or server off also tell us what router you got as you need to assign the local host ip to port 80 or 8080.

If your router has a dynamic dns setting put your dynamic dns name within it the free one you got from the provider of noip.

To see if the server is set correctly goto [a href=\"http://localhost\" target=\"_blank\"]http://localhost[/a]
Wish i new all about php DAM i will have to learn
((EMAIL CODE THAT WORKS))
http://simpleforum.ath.cx/mail2.inc
((PAYPAL INTEGRATION THAT WORKS))
http://simpleforum.a...aypal1_info.inc

#3 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 16 March 2006 - 11:13 PM

Alright in commandprompt, i did nslookup:

C:\documents and settings\owner>nslookup
DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 192.168.254.254: Timed Out
*** Default servers are not available
Default server: Unknown
Address: 192.168.254.254

>

and i have a Speedstream 6520 wireless router/Modem
thanks

#4 redarrow

redarrow
  • Members
  • PipPipPip
  • Advanced Member
  • 7,308 posts
  • Locationlondon

Posted 16 March 2006 - 11:16 PM

[!--quoteo(post=355716:date=Mar 16 2006, 11:13 PM:name=Shizzell)--][div class=\'quotetop\']QUOTE(Shizzell @ Mar 16 2006, 11:13 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
Alright in commandprompt, i did nslookup:

C:\documents and settings\owner>nslookup
DNS request timed out.
timeout was 2 seconds.
*** Can't find server name for address 192.168.254.254: Timed Out
*** Default servers are not available
Default server: Unknown
Address: 192.168.254.254

>

and i have a Speedstream 6520 wireless router/Modem
thanks
[/quote]


You have provided the local meachine ip what your isp ip.


Wish i new all about php DAM i will have to learn
((EMAIL CODE THAT WORKS))
http://simpleforum.ath.cx/mail2.inc
((PAYPAL INTEGRATION THAT WORKS))
http://simpleforum.a...aypal1_info.inc

#5 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 16 March 2006 - 11:17 PM

I went to IPchicken.com:

74.33.105.147

and yes the localhost works

#6 redarrow

redarrow
  • Members
  • PipPipPip
  • Advanced Member
  • 7,308 posts
  • Locationlondon

Posted 16 March 2006 - 11:22 PM

[quote name='Shizzell' date='Mar 16 2006, 11:17 PM' post='355719']
I went to IPchicken.com:

74.33.105.147



[a href=\"http://localhost\" target=\"_blank\"]http://localhost[/a]

what it say on the screen.


Wish i new all about php DAM i will have to learn
((EMAIL CODE THAT WORKS))
http://simpleforum.ath.cx/mail2.inc
((PAYPAL INTEGRATION THAT WORKS))
http://simpleforum.a...aypal1_info.inc

#7 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 16 March 2006 - 11:23 PM

Localhost is exactly like it should be.
It has my webpage that my php files are.

#8 redarrow

redarrow
  • Members
  • PipPipPip
  • Advanced Member
  • 7,308 posts
  • Locationlondon

Posted 16 March 2006 - 11:40 PM

[!--quoteo(post=355722:date=Mar 16 2006, 11:23 PM:name=Shizzell)--][div class=\'quotetop\']QUOTE(Shizzell @ Mar 16 2006, 11:23 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
Localhost is exactly like it should be.
It has my webpage that my php files are.
[/quote]

sorry but your going to have to use the forum of your router.

Becouse when you do a nslookup on any computer conected to the net you should see your isp ip,

your getting your local ip so i think you need to configere the router in there forum ok.


What i am trying to say you see noip can not dynamicly update there dns beacouse your showing a local ip so your sever will never be live also no one will ever see your webpages.

Need the router sorted first ok.

good luck.

Wish i new all about php DAM i will have to learn
((EMAIL CODE THAT WORKS))
http://simpleforum.ath.cx/mail2.inc
((PAYPAL INTEGRATION THAT WORKS))
http://simpleforum.a...aypal1_info.inc

#9 txmedic03

txmedic03
  • Members
  • PipPipPip
  • Advanced Member
  • 313 posts
  • LocationCall, TX, USA

Posted 17 March 2006 - 12:28 AM

If they are getting a 404 (File Not Found) error then my first thoughts would be to check and make sure my router had port 80 (this is the default httpd port) open and directed to my server computer. Then if no one could access the server still I would check to see that my server was listening to port 80 for httpd requests on all IP addresses and not just my loopback or LAN address. This is, of course, where I start because you already stated the server works from your machine. That would be where I would start anyway. Let us know if that does not solve the problem so someone can come up with some more ideas.

SEMPER FIDELIS!

I can't stop you from doing something silly, but at least I can help you do it right.


#10 shortj75

shortj75
  • Members
  • PipPipPip
  • Advanced Member
  • 118 posts
  • LocationPort Huron,mi

Posted 17 March 2006 - 01:53 AM

did you configure the apachi httpd config file to listen to your ip address if not you can open you page by localhost or by [a href=\"http://127.0.0.1\" target=\"_blank\"]http://127.0.0.1[/a] and you wont beable to open it by your address
The Short One

hopfully this helps if it doesn't sorry
i won't write the code for you!!! you don't learn that way

#11 txmedic03

txmedic03
  • Members
  • PipPipPip
  • Advanced Member
  • 313 posts
  • LocationCall, TX, USA

Posted 17 March 2006 - 03:20 AM

There should be a default line in httpd.conf that says "Listen 80". If you changed it, change it back and try again.

SEMPER FIDELIS!

I can't stop you from doing something silly, but at least I can help you do it right.


#12 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 17 March 2006 - 10:34 PM

alright, i changed the listen 80 to:
Listen 74.33.105.147:80

However, apache won't start and in the error log file:
[Fri Mar 17 16:32:14 2006] [crit] make_sock: could not bind to address 74.33.105.147 port 80

go to:
[a href=\"http://www.dslreports.com/forum/remark,15706063\" target=\"_blank\"]http://www.dslreports.com/forum/remark,15706063[/a]
for more in depth information about my system.

help? thanks


#13 shortj75

shortj75
  • Members
  • PipPipPip
  • Advanced Member
  • 118 posts
  • LocationPort Huron,mi

Posted 17 March 2006 - 10:51 PM

this is what my listen sections looks like from my httpd.conf for easyphp1-8
#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
#Listen 3000
#Listen 12.34.56.78:80
Listen 61.68.81.130:80


are you sure you got the right ip address
go to the start button then click run type in cmd in the text box and hit ok
now in the command prompt window type ipconfig and hit enter and you will see ip address and that is your ip address next to it

or did you go to My Network Places on the left click on view network connections the right click you connection go to properties click the advanced tab check the box next to protect my computer and twords the bottom there is a button called settings click on that check all the boxes then hit ok if that doesnt work then i dont know
The Short One

hopfully this helps if it doesn't sorry
i won't write the code for you!!! you don't learn that way

#14 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 17 March 2006 - 10:57 PM

[!--quoteo(post=356044:date=Mar 17 2006, 06:51 PM:name=shortj75)--][div class=\'quotetop\']QUOTE(shortj75 @ Mar 17 2006, 06:51 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
this is what my listen sections looks like from my httpd.conf for easyphp1-8
#
# Listen: Allows you to bind Apache to specific IP addresses and/or
# ports, in addition to the default. See also the <VirtualHost>
# directive.
#
#Listen 3000
#Listen 12.34.56.78:80
Listen 61.68.81.130:80
are you sure you got the right ip address
go to the start button then click run type in cmd in the text box and hit ok
now in the command prompt window type ipconfig and hit enter and you will see ip address and that is your ip address next to it

or did you go to My Network Places on the left click on view network connections the right click you connection go to properties click the advanced tab check the box next to protect my computer and twords the bottom there is a button called settings click on that check all the boxes then hit ok if that doesnt work then i dont know
[/quote]
I changed my listen to: 192.168.254.1
exactly like it said in ipconfig.
then i could not access it via localhost
It brougth up page cannot be displayed

I did change the properties, network places, etc. and my internet basically shuts off. The modem itself doesn't shut off however, but all of my connects go offline and i cannot access any website

#15 shortj75

shortj75
  • Members
  • PipPipPip
  • Advanced Member
  • 118 posts
  • LocationPort Huron,mi

Posted 17 March 2006 - 11:10 PM

i dont know why it shuts down you internet but changing that to you ip address will let other ppl view your page when it is set to 127.0.0.1 it only allows your comp to view the pages no one frome the out internet can view with the ip address you had in there it was lokking for another comp to listen to aand couldnt find it
to view your page you have to type in [a href=\"http://192.168.254.1\" target=\"_blank\"]http://192.168.254.1[/a] or [a href=\"http://192.168.254.1/index.php\" target=\"_blank\"]http://192.168.254.1/index.php[/a] or your mainpage address

you may also have to restart your server
and did you go to mynetwork spaces and turn on the firewall then click settings button and check all the boxes thenk click ok then ok again because if you didnt you or anybody else will beable to view your site because you computer is not setup to run a webserver until you do that
The Short One

hopfully this helps if it doesn't sorry
i won't write the code for you!!! you don't learn that way

#16 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 17 March 2006 - 11:14 PM

[!--quoteo(post=356049:date=Mar 17 2006, 07:10 PM:name=shortj75)--][div class=\'quotetop\']QUOTE(shortj75 @ Mar 17 2006, 07:10 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
i dont know why it shuts down you internet but changing that to you ip address will let other ppl view your page when it is set to 127.0.0.1 it only allows your comp to view the pages no one frome the out internet can view with the ip address you had in there it was lokking for another comp to listen to aand couldnt find it
to view your page you have to type in [a href=\"http://192.168.254.1\" target=\"_blank\"]http://192.168.254.1[/a] or [a href=\"http://192.168.254.1/index.php\" target=\"_blank\"]http://192.168.254.1/index.php[/a] or your mainpage address

you may also have to restart your server
[/quote]

well I changed listen 192.168.254.1:80
and I goto: 192.168.254.1 and I get the website i want
and i changed mirpg.no-ip.info to that address also,and i see it at mirpg.no-ip.info
however my friends cannot see the website.
Help?

#17 shortj75

shortj75
  • Members
  • PipPipPip
  • Advanced Member
  • 118 posts
  • LocationPort Huron,mi

Posted 17 March 2006 - 11:29 PM

after you chane lisyen to you ip address local host doesnt work because it is listening to your ip address now and not local host
did you go to mynetwork spaces and turn on the firewall then click settings button and check all the boxes thenk click ok then ok again because if you didnt you or anybody else will beable to view your site because you computer is not setup to run a webserver until you do that
after all that go to [a href=\"http://192.168.254.1\" target=\"_blank\"]http://192.168.254.1[/a] and it should open your index page or a parent directory page

after you chane lisyen to you ip address local host doesnt work because it is listening to your ip address now and not local host
did you go to mynetwork spaces and turn on the firewall then click settings button and check all the boxes thenk click ok then ok again because if you didnt you or anybody else will beable to view your site because you computer is not setup to run a webserver until you do that
after all that go to [a href=\"http://192.168.254.1\" target=\"_blank\"]http://192.168.254.1[/a] and it should open your index page or a parent directory page
The Short One

hopfully this helps if it doesn't sorry
i won't write the code for you!!! you don't learn that way

#18 txmedic03

txmedic03
  • Members
  • PipPipPip
  • Advanced Member
  • 313 posts
  • LocationCall, TX, USA

Posted 18 March 2006 - 09:57 AM

Do not specify an IP address. If you put it as Listen 80 then your httpd (That's hyper text transfer protocol daemon or in other words Apache) will bind to all IP addresses related to that system on port 80. This means that it will listen on 127.0.0.1 at port 80 for incoming http requests and 192.168.254.1 at port 80. The 192.168.254.1 is your system's IP address on the local network and 127.0.0.1 is a loop back address which is only viewable from the local computer (this is aliased as "localhost"). Requests will come in across your DSL/Cable modem through your router (this may be built into your modem) which more than likely has a dhcp which assigned the 192.168.254.1 IP address to your system your router will forward traffic from the public IP address given to it by the ISPs dhcp through the modem on port 80 to your system on port 80 assuming you have configured it all correctly. It depends on the router and how it is configured as to what your IP address will be. Some routers give a 192.168.xxx.xxx by default and allow you to forward specific ports. The built in router on my modem uses 10.0.xxx.xxx and allows forwarding of ports or to simply DMZ (DeMilitarized Zone) a system on my local network which then inherits the public IP address. I would no recommend DMZing if available on your router, but that is just my humble opinion on the matter. I personally like my linksys router with port forwarding. :-) I hope that this helps you to at least understand IP addresses a little bit better and your httpd listen directive. Fix your configuration and then let's focus back on the problem at hand.

SEMPER FIDELIS!

I can't stop you from doing something silly, but at least I can help you do it right.


#19 Shizzell

Shizzell
  • Members
  • PipPip
  • Member
  • 16 posts

Posted 18 March 2006 - 03:55 PM

Wow guys this was so damn easy. Goto Ipconfig in cmd. change the listen part in easy php to the ip address in ipconfig. with port 80. Port forward port 80 in router and thats it.

[a href=\"http://mirpg.no-ip.info\" target=\"_blank\"]http://mirpg.no-ip.info[/a]

#20 txmedic03

txmedic03
  • Members
  • PipPipPip
  • Advanced Member
  • 313 posts
  • LocationCall, TX, USA

Posted 20 March 2006 - 10:34 AM

Have all my responses fallen on deaf eyes? Change it to port 80 WITHOUT the IP address. This will allow the server to listen to ALL IP addresses bound to that system. If you ever changed the IP address of the system, provided your router is forwarded on port 80, your server will still be accessible across the web.

People that ask questions and never pay attention to the answers will be the death of me.

SEMPER FIDELIS!

I can't stop you from doing something silly, but at least I can help you do it right.





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users