Jump to content


Photo

How to check status of a remote server


  • Please log in to reply
6 replies to this topic

#1 insrtsnhere13

insrtsnhere13
  • Members
  • PipPipPip
  • Advanced Member
  • 64 posts

Posted 18 March 2006 - 04:42 AM

I have a friend running a ventrilo voice chat server on a linux fedora core 4 system. What I need to do is a have php check the status of the computer running the server. Basically, is the computer on or not. If anyone knows how to do this, please post. Thnaks a bunch

#2 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 18 March 2006 - 01:15 PM

Read this tipe [a href=\"http://www.phpit.net/faq/determining-if-a-pc-is-online/\" target=\"_blank\"]here[/a]. I would recommend the secound code snippet for checking whether a server/computer is online or not.

#3 insrtsnhere13

insrtsnhere13
  • Members
  • PipPipPip
  • Advanced Member
  • 64 posts

Posted 18 March 2006 - 02:07 PM

thanks for your reply. that seems like its exactly what i need. I will deffinately try that out and get back to you later on today. thank!

#4 insrtsnhere13

insrtsnhere13
  • Members
  • PipPipPip
  • Advanced Member
  • 64 posts

Posted 18 March 2006 - 03:01 PM

i tried this out a second ago and i changed the ip to my current ip adress as well as the port to one that i know is open on my router. windows firewall is disabled on my computer. yet it comes back as not being online..

#5 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 18 March 2006 - 03:03 PM

try port 80 or 8080 it should work. Also your routers firewall might be blocking the ping so try your routers ip address instead.

#6 insrtsnhere13

insrtsnhere13
  • Members
  • PipPipPip
  • Advanced Member
  • 64 posts

Posted 18 March 2006 - 03:36 PM

no quite sure what you mean by try my routers ip address. im not hosting my own webserver so i belive that i need to use my exact ip adress

alright, i tried port 80 and 8080 and it did not work

#7 insrtsnhere13

insrtsnhere13
  • Members
  • PipPipPip
  • Advanced Member
  • 64 posts

Posted 19 March 2006 - 03:30 PM

anyone else?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users