Jump to content

Archived

This topic is now archived and is closed to further replies.

tiki

No input file specified ERROR

Recommended Posts

Ok I have tested this on two sites/hosts/domains. One works the other doesnt.

It doesnt work here:
[a href=\"http://www.mileswjohnson.com/contact/\" target=\"_blank\"]http://www.mileswjohnson.com/contact/[/a]

But then this works, but isnt showing header and footer
[a href=\"http://www.mileswjohnson.com/contact\" target=\"_blank\"]http://www.mileswjohnson.com/contact[/a]

And heres the site were it does work
[a href=\"http://www.inferiaefashion.com/personal/Portfolio/contact/\" target=\"_blank\"]http://www.inferiaefashion.com/personal/Portfolio/contact/[/a]

It does that for all the pages, how can I fix it?

Share this post


Link to post
Share on other sites
[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--][a href=\"http://www.mileswjohnson.com/contact/\" target=\"_blank\"]http://www.mileswjohnson.com/contact/[/a][/quote]
Page doesn't even exist!!!

[a href=\"http://www.mileswjohnson.com/contact\" target=\"_blank\"]http://www.mileswjohnson.com/contact[/a]

are you sure these are the same files as PHP wont parse the header and that or a less yours using the html withing the (<?php ?>) maby echo the code of each page to us as we can't help from the HTML outputted..

Share this post


Link to post
Share on other sites
Because your domain works, and if you add INDEX.HTML to the end of your domain name, I do get a page, either you have specified the wrong page name in your default doc type for that server I.E. you are using CONTACT.PHP but specifiec INDEX.PHP so it won't automatically call up the file, and give the error you got that means that PHP was asked to open a file that it can't find,

or,


You are on a LINUX server and your default doc type is for example index.php but your file is saved as INDEX.PHP... CAPS MATTER IN LINUX!!!

Share this post


Link to post
Share on other sites
Btw I am using mod_rewrite.

In the index.php file it includes the other files like contact.php to make index.php?x=contact.
Then mod_rewrite should change it to /contact/

But its being retarded?

Share this post


Link to post
Share on other sites
[!--quoteo(post=357941:date=Mar 24 2006, 03:15 PM:name=tiki)--][div class=\'quotetop\']QUOTE(tiki @ Mar 24 2006, 03:15 PM) [snapback]357941[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Btw I am using mod_rewrite.

In the index.php file it includes the other files like contact.php to make index.php?x=contact.
Then mod_rewrite should change it to /contact/

But its being retarded?
[/quote]

I doubt [i]it's[/i] being retarded, as this is actively developed. I am going t say it's a user error.

You can post your configuration files and maybe we could help, but other than that we have nothing to go on.

Share this post


Link to post
Share on other sites
Well thats the thing, the mod_rewrite and php works fine on inferiaefashion.com but not on mileswjohnson.com.

I was reading the help on my host and they say mod_rewrite is active but apache is not turned on, im guessing thats the problem. Is there a string to enable apache thru .htaccess?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.