Jump to content

Archived

This topic is now archived and is closed to further replies.

sambib

How do I stop these characters showing up ----> �

Recommended Posts

Hi I have a cms which gets content and displays it in php pages and I can't suss out how get rid of these types of characters [b]� [/b] (instead of apostrophes, single quotes or dashes etc).

I use addslashes before inputing the data- $d = addslashes($_POST['content']);

and I uses stripslashes when displaying the data

I've set magic quotes to off or on it doesn't seem to make a difference....?

any clues greatly appreciated...

Share this post


Link to post
Share on other sites
I may be wrong, but I THINK they happen because the characters are not what you think they are... let me give an example, then you can tell me I'm wrong...

when you do " in m$ word, it changes it the those funny " that are different when you start the quote than when you end the quote, like the first ones are upside down or whatever. I think that is what you are seeing... I have dealt with them in the past with str_replace()

Share this post


Link to post
Share on other sites
[!--quoteo(post=359646:date=Mar 29 2006, 11:07 PM:name=AV1611)--][div class=\'quotetop\']QUOTE(AV1611 @ Mar 29 2006, 11:07 PM) [snapback]359646[/snapback][/div][div class=\'quotemain\'][!--quotec--]
I may be wrong, but I THINK they happen because the characters are not what you think they are... let me give an example, then you can tell me I'm wrong...

when you do " in m$ word, it changes it the those funny " that are different when you start the quote than when you end the quote, like the first ones are upside down or whatever. I think that is what you are seeing... I have dealt with them in the past with str_replace()
[/quote]

I changed the charset of my pages to charset=utf-8 and it seems to have done the trick...

Share this post


Link to post
Share on other sites
I did change my charset to utf-8, and I am still getting issues.  I get â€, on some pages and  on others.  Some of the chars I find hiding in empty spaces.  I just delete the spaces, and sometimes they go away, but I have NO idea what is going on here...

Share this post


Link to post
Share on other sites
[url=http://jamz1019.com]http://jamz1019.com[/url] That is where they are.  They are all over the place on various pages.

Share this post


Link to post
Share on other sites
I have found that the only place this happens is on the host servers they use.  It seems to work fine everywhere else on the planet, so I am switching them to different servers...

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.