Jump to content

Archived

This topic is now archived and is closed to further replies.

swarren@verisign.com

Unable to load dynamic library 'C:\PHP\ext\php_ssh2.dll' - The specified module could not be found

Recommended Posts


Hi,


With IIS, I keep getting a module load error for ssh2 during the a doc.php request (any php file).


PHP Warning: PHP Startup: Unable to load dynamic library 'C:\PHP\ext\php_ssh2.dll' - The specified module could not be found. in Unknown on line 0



Some info as to my configuration:

1) In C:\PHP\php.ini, I have:

extension_dir="C:\PHP\ext"
;followed by
extension=php_ssh2.dll


2) The path set to include C:\PHP directory (truncated example below)

PATH=C:\WINDOWS\system32;C:\WINDOWS; (cut) c:\php (cut) ;C:\Tools\exe

However, I am unsure of:

PATHEXT .COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH



3) C:\PHP\ext\php_ssh2.dll located appropriately in the correct location. (Shown below)

C:\PHP\ext>dir
Volume in drive C is Local Disk
Volume Serial Number is XXXX-XXXX

Directory of C:\PHP\ext

03/29/2006 01:47 PM <DIR> .
03/29/2006 01:47 PM <DIR> ..
03/29/2006 04:00 PM 127,039 php_ssh2.dll
1 File(s) 127,039 bytes
2 Dir(s) 66,811,842,560 bytes free

C:\PHP\ext>



4) Note: Tested with php_ssh2.dll in c:\WINDOWS\SYSTEM32 with same result.


5) IUSR / Internet Guest User has full control (currently) to C:\PHP and sub-dirs (security hole?)


6) Note: php.ini is working / being found (or I wouldn't get this error).

7) Before adding this module (ssh2), PHP pages appeared to be working fine.



Guesses: Either this error is a permissions issue, dependency or an IIS configuration issue.

Summary: What are my issues in security, configuration and are there dependent packages?

-=> SW

Share this post


Link to post
Share on other sites
This may or may not be your problem but never put this as your extension in the php.ini file:
extension_dir="C:\PHP\ext"

always specify the last slash
extension_dir="C:\PHP\ext\"

not saying that this is the problem, but its worth a try :)

if that doesn't work try this:

extension_dir="C:\\PHP\\ext\\"

Share this post


Link to post
Share on other sites
[!--quoteo(post=360155:date=Mar 30 2006, 01:14 PM:name=lead2gold)--][div class=\'quotetop\']QUOTE(lead2gold @ Mar 30 2006, 01:14 PM) [snapback]360155[/snapback][/div][div class=\'quotemain\'][!--quotec--]
This may or may not be your problem but never put this as your extension in the php.ini file:
extension_dir="C:\PHP\ext"

always specify the last slash
extension_dir="C:\PHP\ext\"

not saying that this is the problem, but its worth a try :)

if that doesn't work try this:

extension_dir="C:\\PHP\\ext\\"
[/quote]



Lead2gold,

Thanks - Unsuccessfully, I tried both methods you suggested. I am sure the suggestions were tested because the latter suggestion yielded:

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\\PHP\\ext\\php_ssh2.dll' - The specified module could not be found. in Unknown on line 0

Note: Interestingly enough, the first suggestion, extension_dir="C:\PHP\ext\", did not change the original error. Again, I received:

PHP Warning: PHP Startup: Unable to load dynamic library 'C:\PHP\ext\php_ssh2.dll' - The specified module could not be found. in Unknown on line 0

-=> SW

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.