Jump to content

Archived

This topic is now archived and is closed to further replies.

lssjg

MYSQL - installation

Recommended Posts

hey, you guys recently (about two weeeks ago) helped me install php, mysql, apache, and phpmyadmin and it worked... well done!


Only problem... about 4 days ago, for other reasons.... my computer went dead so i took it back to a restore point a few days before i installed these programs.... now.. they obviouslt became uninstalled... so i deleted the files as they weren't doing anything and went to go and re-install...

NOW FOR THE PROBLEM

I can't get it installed and working again..... i got apache and php working... i got php messages coming up and etc,....

BUT mysql.... and phpmyadmin....


i did phpinfo.... and i couldn't find the mysql bit in it (which is usually around the middle i can remember)!

But anyway, ignoring this i went and extracted phpmyadmin into www and using the old threads (the ones i last posted in), i edited php.ini and a file in the libraries folder. and this and that...


but when go to localhost/phpinfo.php (just to make sure it was working), because i keep a php file there with the phpinfo() in it.... anyway... so YES IT WAS WORKING!

Then i go to localhost/phpmyadmin and an error comes up

_________________
|[u][!--coloro:#FF0000--][span style=\"color:#FF0000\"][!--/coloro--]phpMyAdmin - Error[!--colorc--][/span][!--/colorc--][/u]|
Cannot load mysql extension. Please check your PHP configuration. - Documentation


Sorrry for my bad drawings... but anyway documentation was a link to the faq which i read and it gave no help - big suprise...

oh... and also the first line is meant to be in a red box.... not read writing.... its meant to have white writing (i think... or is it black - anyway u get the picture)!


thanks in advance for anyone who helps!

Share this post


Link to post
Share on other sites
You will need to enable the MySQL extension for PHP. Have alook at [a href=\"http://www.phpfreaks.com/forums/index.php?showtopic=87276\" target=\"_blank\"]this[/a] thread it should help you to enable the MySQL Extension.

Share this post


Link to post
Share on other sites
done that and i have even gone through all the file editing and everything an extra time just in case...


that includes that.... i double checked everything before asking here



thanks anyway...



any more HELP PLEASE!

Share this post


Link to post
Share on other sites
Make sure PHP is using the correct php.ini file by checking this with the phpinfo() function. Where is the php.ini file you are editing?

If php is using the wrong file then ad this directive to to your httpd.conf file:
[code]#PHPIniDir
PHPIniDir "C:/WINDOWS"[/code]change C:/WINDOWS to where you are editing the php.ini file to. dont add php.ini to the end just do it to the folder it is been stored in.

Also make sure you are restart Apache.

Share this post


Link to post
Share on other sites
[!--quoteo(post=361158:date=Apr 3 2006, 04:13 AM:name=wildteen88)--][div class=\'quotetop\']QUOTE(wildteen88 @ Apr 3 2006, 04:13 AM) [snapback]361158[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Make sure PHP is using the correct php.ini file by checking this with the phpinfo() function. Where is the php.ini file you are editing?

If php is using the wrong file then ad this directive to to your httpd.conf file:
[code]#PHPIniDir
PHPIniDir "C:/WINDOWS"[/code]change C:/WINDOWS to where you are editing the php.ini file to. dont add php.ini to the end just do it to the folder it is been stored in.

Also make sure you are restart Apache.
[/quote]



thanks sp much!


it worked......


oh by the way i can't remember if it was like this before.... but!...


down the botom of of the main phpmyadmin page it has

IN RED



The mbstring PHP extension was not found and you seem to be using a multibyte charset. Without the mbstring extension phpMyAdmin is unable to split strings correctly and it may result in unexpected results

Share this post


Link to post
Share on other sites
To sort that out you just got to enable the php_mbstring.dll extension in the php.ini and the message should go away.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.