Jump to content


Photo

CGI Timeout on IIS driving me nuts! Can't get it to leave -- help appreciated.


  • Please log in to reply
3 replies to this topic

#1 nielsena54

nielsena54
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 03 April 2006 - 09:03 PM

Hey all,

I am writing PHP scripts to do some data transfer. One of the tables that I am importing is 400000+ records long. My challenge is avoiding the CGI timeout error in IIS. After 5 minutes it displays, no matter what I do.

I have already used MetaBase to change the default value to a high number (24 hrs, or 86400 seconds). I have also changed the property in the IIS Manager GUI to reflect this change. I have restarted the server and the computer multiple times, but to no avail.

I would just switch to Apache, except that I am transferring data into Microsoft SQL on a Microsoft Server running IIS .Net web services.

The exact error reads:

"CGI Timeout

The specified CGI application exceeded the allowed time for processing. The server has deleted the process."

Thanks in advance!

#2 Barand

Barand
  • Moderators
  • Sen . ( ile || sei )
  • 18,017 posts

Posted 03 April 2006 - 11:51 PM

I wouldn't attempt to import that many recs through a web script. Do it off-line.

What are you importing to and from - there may be a quicker method?
If you are still using mysql_ functions, STOP! Use mysqli_ or PDO. The longer you leave it the more you will have to rewrite.

Donations gratefully received






moon.png

|baaGrid| easy data tables - and more
|baaChart| easy line, column and pie charts

#3 nielsena54

nielsena54
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 04 April 2006 - 02:38 AM

[!--quoteo(post=361405:date=Apr 3 2006, 05:51 PM:name=Barand)--][div class=\'quotetop\']QUOTE(Barand @ Apr 3 2006, 05:51 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
I wouldn't attempt to import that many recs through a web script. Do it off-line.

What are you importing to and from - there may be a quicker method?
[/quote]

I am importing from Dataflex using an ODBC driver. I am doing it offline in the sense that it is on an intranet, definitely not a public script. This is the most efficient method that I have found so far; any other transfer options cost a whole lot of money because of the unique nature of DataFlex.

As I'm writing this, I am realizing that I could maybe use Access with the same ODBC driver.... and make something work that way....

Anyway, I am still curious as to how to get rid of this cgi timeout error. In the meantime, I will either use a local Apache server on the same network or try some Access methods.

thanks!

#4 craygo

craygo
  • Staff Alumni
  • Advanced Member
  • 1,973 posts
  • LocationRhode Island

Posted 04 April 2006 - 03:12 AM

Go here
[a href=\"http://www.iis-resources.com/modules/AMS/article.php?storyid=76\" target=\"_blank\"]http://www.iis-resources.com/modules/AMS/a....php?storyid=76[/a]

You can change the setting here, But sometimes It doesn't work. I had to do mine thru a dos command. I forgot how to do it but will post when I find it.

Ray




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users