Jump to content

Archived

This topic is now archived and is closed to further replies.

mancroft

phpmyadmin error message: $cfg['Servers'][$i]['pmadb']

Recommended Posts

Bona vada

 

I have just set up a database and put two tables into it but phpmyadmin gives the following message (see below the actual question which comes next):

 

My actual question is:

 

what is $cfg[\'Servers\'][$i][\'pmadb\']

 

and how do I

 

\"just put your current database name in $cfg[\'Servers\'][$i][\'pmadb\']\"

 

????

 

Thanks!

 

 

 

 

 

 

>>>>>>>>>>>>>>>>>>>>>>>>

Error

The additional Features for working with linked Tables have been deactivated. To find out why click here.

>>>>>>>>>>>>>>>>>>>>>>>>

 

which leads to:

 

>>>>>>>>>>>>>>>>>>>>>>>>

Database cos_cart running on localhost

PMA Database ... not OK[ Documentation ]

General relation features Disabled

>>>>>>>>>>>>>>>>>>>>>>>>

 

and the link to documentation leads to:

 

>>>>>>>>>>>>>>>>>>>>>>>>

$cfg[\'Servers\'][$i][\'pmadb\'] string

Starting with version 2.3.0 phpMyAdmin offers a lot of features to work with master / foreign - tables. To use those as well as the bookmark feature you need special tables with a predefined structure, which we explain below.

If you are the only user of this phpMyAdmin installation, you can use your current database to store those special tables; in this case, just put your current database name in $cfg[\'Servers\'][$i][\'pmadb\'].

 

If you are setting up a multi-user phpMyAdmin installation, you will need to create a new db and setup special privileges, so, as superuser:

 

 

create a new database for phpmyadmin:

CREATE DATABASE phpmyadmin;

Note that \"controluser\" must have SELECT, INSERT, UPDATE and DELETE privileges on this database. Here is a query to set up those privileges (using \"phpmyadmin\" as the database name, and \"pma\" as the controluser):

GRANT SELECT,INSERT,UPDATE,DELETE ON phpmyadmin.* to \'pma\'@\'localhost\';

do not give any other user rights on this database.

enter the databasename in $cfg[\'Servers\'][$i][\'pmadb\']

>>>>>>>>>>>>>>>>>>>>>>>>

Share this post


Link to post
Share on other sites

Is this setup on a local server, on webhost supplied webspace?

 

I beleive you can turn of these advanced features (that dont exist on mySql) in the phpMyAdmin config files.

 

the array it is talking about, is part (as I understand) of the phpMyAdmin configuration files, its seems to be asking you to insert your databasename and details into this array so that hphMyAdmin can use the advanced features.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.