Jump to content


Photo

help with oscommerce , can anyone help me please ....


  • Please log in to reply
3 replies to this topic

#1 the apprentice webmaster

the apprentice webmaster
  • Members
  • PipPipPip
  • Advanced Member
  • 65 posts

Posted 14 April 2006 - 08:29 AM

guys i am trying the oscommerce thing , but when i run the script i get this message

Warning: Installation directory exists at: C:/Program Files/xampp/htdocs/catalog/install. Please remove this directory for security reasons.

so guys i have a file inside the catalog folder like catalog\ instal\instal.php should i deletes the instal.php to get rid of the warnings so guys pls help thx for everything

#2 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 14 April 2006 - 10:09 AM

Either delete or rename the install folder and everthing will be all fine. This is not a PHP error message but an error message being produced by oscommerce.

Now make sure you have ran through the required steps oscommerce may need to be fully installed, to chekc you mighjt want to read through the documentation, then just delete or rename the install folder. You're best of just deleting the install folder for added security.

#3 the apprentice webmaster

the apprentice webmaster
  • Members
  • PipPipPip
  • Advanced Member
  • 65 posts

Posted 15 April 2006 - 05:52 AM

[!--quoteo(post=364741:date=Apr 14 2006, 06:09 AM:name=wildteen88)--][div class=\'quotetop\']QUOTE(wildteen88 @ Apr 14 2006, 06:09 AM) View Post[/div][div class=\'quotemain\'][!--quotec--]
Either delete or rename the install folder and everthing will be all fine. This is not a PHP error message but an error message being produced by oscommerce.

Now make sure you have ran through the required steps oscommerce may need to be fully installed, to chekc you mighjt want to read through the documentation, then just delete or rename the install folder. You're best of just deleting the install folder for added security.
[/quote]


hi i'm back and maybe ya can help me some more , i delete the instal problem , but the warning is still there now i am getting this new warning message

Warning: session_start() [function.session-start]: open(/tmp\sess_ed0bafd7234ed64ebd2a5b0e428bf060, O_RDWR) failed: No such file or directory (2) in C:\Program Files\xampp\htdocs\catalog\includes\functions\sessions.php on line 97

Warning: session_start() [function.session-start]: Cannot send session cookie - headers already sent by (output started at C:\Program Files\xampp\htdocs\catalog\includes\functions\sessions.php:97) in C:\Program Files\xampp\htdocs\catalog\includes\functions\sessions.php on line 97

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at C:\Program Files\xampp\htdocs\catalog\includes\functions\sessions.php:97) in C:\Program Files\xampp\htdocs\catalog\includes\functions\sessions.php on line 97

Warning Warning: Installation directory exists at: C:/Program Files/xampp/htdocs/catalog/install. Please remove this directory for security reasons.

Warning Warning: I am able to write to the configuration file: C:/Program Files/xampp/htdocs/catalog/includes/configure.php. This is a potential security risk - please set the right user permissions on this file.

Warning Warning: The sessions directory does not exist: /tmp. Sessions will not work until this directory is created.


pls anyone help , i'll be waiting for any advice thx once again

#4 Advancewebsoft

Advancewebsoft
  • New Members
  • Pip
  • Newbie
  • 8 posts

Posted 01 July 2006 - 11:07 PM

Hello,

To remove these messages, first of all
1) Make sure you have a /tmp directory, it exists. The /tmp directory is specified in a php.ini file, and if you're using Osc Ms2.2 in the admin->Configuration->Sessions.
2) To remove the session error you could also use the define('STORE_SESSIONS', 'mysql'); in the catalog/includes/configure.php file.
3) Delete the installation directory
4) As you're using windows, make your catalog/includes/configure.php - non writable, set 'read-only' checkbox in the file atrributes.

Good luck.
Best,
Advance Team
Official site http://www.advancewebsoft.com
Oscommerce Solutions: http://www.advancewe...oscommerce.html




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users