Jump to content

Archived

This topic is now archived and is closed to further replies.

rustybadge

I need a hero!

Recommended Posts

This is likely easy, but I know I am doing a simple thing wrong.... please please please help!

I have a form here: www.rustybadge.com/lang/hastadmin.php (log in with frida / dork) - when the text is entered and you press submit, it changes www.rustybadge.com/lang/hast.php - it's a VERY simple CMS!!

I tried to add an image upload feature to this, and I just CAN'T get it working! ! Can anyone help??

I just added the line: "<p><?php print("<img src=\"$final_filename\">");?></p>" into hast.php. This may be wrong in itself...

Share this post


Link to post
Share on other sites
what kind of server ?
Win / Nix? (mac is Nix)


you have GD lib installed ?

on your form are you using enctype="multipart/form-data" ?

you have a '<input type="hidden" name="MAX_FILE_SIZE" value="PUT ANY NUMBER HERE" />' defined in that form ?

where you uploading to?

best one:
are the permissions set ?











Share this post


Link to post
Share on other sites
[!--quoteo(post=366176:date=Apr 18 2006, 03:32 PM:name=Acey)--][div class=\'quotetop\']QUOTE(Acey @ Apr 18 2006, 03:32 PM) [snapback]366176[/snapback][/div][div class=\'quotemain\'][!--quotec--]
what kind of server ?
Win / Nix? (mac is Nix)
you have GD lib installed ?

on your form are you using enctype="multipart/form-data" ?

you have a '<input type="hidden" name="MAX_FILE_SIZE" value="PUT ANY NUMBER HERE" />' defined in that form ?

where you uploading to?

best one:
are the permissions set ?
[/quote]


windows

no idea what gc lib is

not sure where I am uploading to, but i want it to be a folder called tempimg

what should the permissions be?

Share this post


Link to post
Share on other sites
ok you may not need gd lib (Makes/modifys images) but it's probably on, most php builds for windows are.

ok if your uploading to say c:\path\to\tempimg\

you need to contact the sys admin & have the permissions on \tempimg\
set to read, write, execute for all.

once that's done & you have the upload set correctly your image uploads should work.



Share this post


Link to post
Share on other sites
[!--quoteo(post=366191:date=Apr 18 2006, 04:04 PM:name=Acey)--][div class=\'quotetop\']QUOTE(Acey @ Apr 18 2006, 04:04 PM) [snapback]366191[/snapback][/div][div class=\'quotemain\'][!--quotec--]
ok you may not need gd lib (Makes/modifys images) but it's probably on, most php builds for windows are.

ok if your uploading to say c:\path\to\tempimg\

you need to contact the sys admin & have the permissions on \tempimg\
set to read, write, execute for all.

once that's done & you have the upload set correctly your image uploads should work.
[/quote]


Hi there,

I changed the CHMOD permissions in my image folder, and the images are still not ending up there... nor are they being printed to www.rustybadge.com/lang/hast.php - thanks anyway...

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.