Jump to content

Archived

This topic is now archived and is closed to further replies.

WormTongue

MYSQL databse isn't working!

Recommended Posts

I just installed the mysql database on my RH 9.0 webserver. I did not install it to the default path, i installed it where i wanted it to go. Now, when i try to access the database through the web, i don\'t get any data. I can connect just fine, but nothing shows up. All i get is \"\"); } ?> \". I\'m thinking that i don\'t have the server configured correctly to point to the data when it starts. So, my question is where would i go about configuring mysql to look in the correct directory? I\'ve been editing some files that i think are the ones i need to change, but nothing has worked yet. Thanks for the help.

Share this post


Link to post
Share on other sites

php was compiled to work with mysql, pointing to the directory where you installed mysql? if \"look in the correct directory\" implies finding the database, you can start mysql with the --datadir=/path/to/data switch.

Share this post


Link to post
Share on other sites

The way i start mysql right now is by this...

 

/data/mysql/mysql/support-files/mysql.server start 

 

So, then i would need to start the sql database by this...

 

/data/mysql/mysql/support-files/mysql.server start --datadir=/data/mysql/mysql/data

 

Is this correct?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.