Jump to content

Archived

This topic is now archived and is closed to further replies.

gerkintrigg

No errors are displayed

Recommended Posts

Normally this is a good thing right?
Well I remember on my old server I could have lots of lovely red errors when I made a mistake with coding. These are just not there any more, the script stops, but no errors. Is there a way to turn these back on as I found them REALLY useful in debugging.

Thanks in advance.

Share this post


Link to post
Share on other sites
Yes

To do so you must be able to have access to a file called php.ini and to be able to restart the webserver.

If have access to the abpve then find and edit your php.ini. Now fuind the following line:
[code]display_errors = Off[/code] change Off to [b]On[/b]

If you want your error messages to be red then find the following:
[code]; String to output before an error message.
;error_prepend_string = "<font color=ff0000>"

; String to output after an error message.
;error_append_string = "</font>"[/code]and remove the semi-colons infront of [b]error_prepend_string[/b] and [b]error_append_string[/b]

Now save your php.ini file and restart your webserver for the changes to be made.

Share this post


Link to post
Share on other sites
Thanks.
I'm still having problems with the permissions for the folder that the php.ini is in. I should have full access to everything, but for some reason the write permissions are set to no (that's kinda what I want) but when I change them to allow tyhe upload of the php.ini via FTP it says permissions are such that I cannot put the file. I've tried to do it via SSH (is this right) but active X is not installed. I've looked at loads of tutorials and scripts to do this, I've tried logging in as everything I can (using the plesk control panel) but I can't find a way of allowing myself in. (weird saying it like that...)

I should have SSH access and FTP access to all of the domains on my server and can probably find the root folder of the server if I looked for it.

Please help. I'm like a dog chasing his tail - desperately - and not getting anywhere. - At least I now have a php.ini that does what I want it to do. I just can't get it on to the server...

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.