Jump to content


Photo

apache permission error


  • Please log in to reply
6 replies to this topic

#1 tazgalsinh

tazgalsinh
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 22 January 2003 - 10:11 PM

with apache installed on my windows 2000 pro system. when i type in http://localhost it comes up with the following error.

Forbidden
You don\'t have permission to access / on this server.


--------------------------------------------------------------------------------

Apache/1.3.27 Server at localhost Port 80

if any one can help me and need more info please let me as this is making my studies more difficult. thanks

#2 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 22 January 2003 - 10:56 PM

check your Allow from and Deny from directives in the Directory directive.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#3 maddogradio

maddogradio
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 04 February 2003 - 10:00 PM

Where would I find the Directory directive? I read through the Apache documentation but I just didn\'t get it.

Can you give me an example of what it should look like?

Thanks for helping a noob,
Maddog
Maddog Rock Radio
[br]All Metal, All The Time!
[br]Home of the
[br] Heavycore Hour

#4 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 04 February 2003 - 10:29 PM

within apache\'s httpd.conf file is a directive in this type of format:

<Directory /path/to/web/root>
Order allow,deny
Allow from all
</Directory>


it typically has more options set.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#5 maddogradio

maddogradio
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 04 February 2003 - 11:33 PM

That\'s why I am confused. There is no directive there. I am using Apache 1.3.26 and I searched the httpd.conf file to no avail for a Directory Directive. I wrote in the one you posted but I get an error when I try to restart the server with appachectl command. Where in the httpd.conf file shoud this directive be placed?

I am trying to set up a phpNuke site and everything works including phpMyAdmin from the /var/www/html directory. I tried setting up the phpnuke in a directory like this /var/www/phpnuke

I created the DNS entries and the Virtual Host in the vhost.conf file I just get the 403 Frobidden access denied page when I try to access it. It says I don\'t have permission to access / on this server.

Thanks for the help! :lol:
Maddog Rock Radio
[br]All Metal, All The Time!
[br]Home of the
[br] Heavycore Hour

#6 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 05 February 2003 - 12:25 AM

and you have non ran apache previously? it sounds like you are missing some important settings, although i\'m only familiar with 2.0. can you link or email your httpd.conf? effigy at devoid dot org.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#7 maddogradio

maddogradio
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 05 February 2003 - 07:00 PM

I am still in need of help for this problem.

If anyone out there wants to help me beat this thing shoot me an email to maddog@headrock.net

Thanks
Maddog Rock Radio
[br]All Metal, All The Time!
[br]Home of the
[br] Heavycore Hour




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users