Jump to content

Archived

This topic is now archived and is closed to further replies.

mgm_03

Darwin ...Permission denied

Recommended Posts

I enter ./bin/mysqld_safe ..and.. voila ! Just in case once isn\'t enough my own computer rejects me 6 extra times!! :cry:

 

touch: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

chown: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

Starting mysqld daemon with databases from /usr/local/mysql/data

./bin/mysqld_safe: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

rm: /usr/local/mysql/data/Marks-Computer.local..pid: Permission denied

./bin/mysqld_safe: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

tee: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

030809 16:31:34 mysqld ended

tee: /usr/local/mysql/data/Marks-Computer.local..err: Permission denied

 

...the dumbass

Share this post


Link to post
Share on other sites

Probably need to run this as root, or su\'d as root.

Share this post


Link to post
Share on other sites

You\'re right.

 

I tried this and while it didn\'t work, at least all the rejection stopped.

 

[Marks-Computer:/usr/local/mysql] mark% sudo ./bin/mysqld_safe

Password:

Starting mysqld daemon with databases from /usr/local/mysql/data

030809 20:11:09 mysqld ended

Share this post


Link to post
Share on other sites

look in your data folder for a file called hostname.err: it will provide you with further details of why this is happening. you may also want to append an & to the end of your command, so the database will not take up your terimnal screen.

Share this post


Link to post
Share on other sites

Thank you.

 

In the data directory I only found a file called:

Mark\'s-Computer.local..err

 

I don\'t know why there are two periods between local and err? Anyway I\'ve tried to open the file using :

 

 

vi Marks-Computer.local.err

(No terminal database found)

 

this is so painful

Share this post


Link to post
Share on other sites

you may need to specify where your databases are... for example i use:

 

./bin/safe_mysqld --user=mysql --datadir=/usr/local/mysql/data &

Share this post


Link to post
Share on other sites

After alot of frustration and searching the web everywhere, I gave up and went to Marc L\'s site again. I used his script to remove the files and then started a new download/install all over again.

 

upon issuing:

mark% sudo ./bin/mysqld_safe&

 

I\'m asked for my Password ...on the same line I just typed and I can see the letters of my passwrod as I type WTF???

 

Next I try:

 

mark% su root

(enter password)

 

mark# ./bin/mysqld_safe &

 

I get:

 

[Marks-Computer:/usr/local/mysql] mark# Starting mysqld daemon with databases from /usr/local/mysql/data

030811 16:12:53 mysqld ended

 

I check the err log file ...

 

030811 16:12:52 mysqld started

030811 16:12:52 Can\'t start server: Bind on TCP/IP port: Address already in use

030811 16:12:53 Do you already have another mysqld server running on port: 3306 ?

030811 16:12:53 Aborting

 

030811 16:12:53 /usr/local/mysql/bin/mysqld: Shutdown Complete

 

030811 16:12:53 mysqld ended

 

-----------------------------------

Then I did a google search on the entire line containing \"Do you already...3306?\". I read on the University of Washington website (Washington) that I need to create/edit a .my.cnf file. Then select a different port and put the file in my home directory. So, this is what I put into the .my.cnf file:

 

[mysqld]

port=3305

socket=/Users/mark/mysql.sock

basedir=/Users/mark/mysql

datadir=/Users/mark/mysql/data

 

[client]

port=3305

socket=/Users/mark/mysql.sock

 

 

So I used port 3305 instead of 3306. I checked /Users/mark directory and the file is there with (rw_r__r__ permissions). It does not appear that the file had any effect. I get the same message when I run mark# ./bin/mysqld_safe&

 

[Marks-Computer:/usr/local/mysql] mark# Starting mysqld daemon with databases from /usr/local/mysql/data

030811 16:42:50 mysqld ended

 

Also, I couldn\'t sudo because the same thing happened with my password (see above). So, I switched to mark# to get to where I am now....which is virtually where I started

Share this post


Link to post
Share on other sites

no...I just bought a Powerbook with 10.2.6 ...MySQL is not installed

 

My first install of MySQL was succesful until last week...don\'t know what changed but I noticed the problem when I tried to install phpMyAdmin. Upon trying to get into mysql , nothing was workng. Don\'t know if it\'s due to PMA or that\'s just coincidence.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.