Jump to content

Archived

This topic is now archived and is closed to further replies.

ryuuseigun

Changing max_allowed_packet on a shared server

Recommended Posts

Hi, I was wondering whether there was a way to change the max_packet_size on a shared server? I'm running Apache 1.3.31 (Unix), PHP 4.3.11 and MySQL 4.0.16, but cannot access the my.cnf file. If any more details are needed, please let me know; I'm very much a newbie with this. Any help will be much appreciated.

Share this post


Link to post
Share on other sites
I don't think so -- but in general, you shouldn't need to change this size, which is usually set rather conservatively. If this has to do with storing binary data, then there are other, more desirable workarounds. Please clarify.

Share this post


Link to post
Share on other sites
[!--quoteo(post=370300:date=May 2 2006, 02:07 AM:name=fenway)--][div class=\'quotetop\']QUOTE(fenway @ May 2 2006, 02:07 AM) [snapback]370300[/snapback][/div][div class=\'quotemain\'][!--quotec--]
I don't think so -- but in general, you shouldn't need to change this size, which is usually set rather conservatively. If this has to do with storing binary data, then there are other, more desirable workarounds. Please clarify.
[/quote]

Yes, I'm trying to store binary data in the database, namely files whose individual file sizes are greater than the max_allowed_packet. Currently, storing smaller files has been no problem at all. It seemed like there should be better ways to get around the problem, but I had no idea where to begin looking, so the tutorials/forum threads I did find were all related to increasing max_allowed_packet.

Share this post


Link to post
Share on other sites
I can't seem to locate the tutorial, but basically, you simply break up your binary data into reasonably-sized chunks, and then put it back together on the way out.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.