Jump to content

Archived

This topic is now archived and is closed to further replies.

robmiller

Installing MySQL

Recommended Posts

I\'ve installed MySQL 4.0.14 on Windows XP. I\'m running the Xitami webserver with PHP installed.

 

However, there\'s a problem.

 

Whenever I try to connect to the database, with PHPMyAdmin or with a database manager, or through a PHP script, it gives me this error:

 

#1045 - Access denied for user: \'rob@localhost\' (Using password: YES)

 

 

 

Any ideas guys? It\'s probably a noob mistake, but I\'m new to MySQL.

 

 

 

Thanks everyone,

 

Rob

Share this post


Link to post
Share on other sites

either your password is incorrect, or that user does not have permissions to access the specified database. for the former, check your spelling and case; for the latter, login into the command interface via root and run a grant statement.

Share this post


Link to post
Share on other sites

I\'ve checked many times and my password is correct.

 

I tried logging in as root, and it still doesn\'t work.

 

 

:erk:

Share this post


Link to post
Share on other sites

have you tried via the web or the command line? are you absolutley sure what your root password is? you may want to get the instructions from mysql.com of how to reset it to be sure. try using a blank password -- i believe that is the default. the only other thing i can think of is file permissions, however i am not sure how these are handled in windows.

Share this post


Link to post
Share on other sites

I tried to set the MySQL privilieges but when i type

mysql_install_db in c:mysqlscripts

it can\'t be executed and said its not a executable command inside the Command Prompt

I am using Windows XP Professional

 

please help

Thank you

Share this post


Link to post
Share on other sites

Hi rob,

 

when you are connecting, are you using an IP address or are you using localhost, when you are running it locally localhost works best. Just thought Id mention that cos when I set up phpmyadmin I had that same error message you are getting, then I changed the IP address to localhost and it went away. Just a thought

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.