Jump to content


Photo

issue compiling binary php cli in PHP 5.1.3 (and 5.1.2)


  • Please log in to reply
No replies to this topic

#1 johnnysoj

johnnysoj
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 03 May 2006 - 05:35 PM

Hello all.

I'm having an issue compiling PHP, more specifically, the PHP CLI.
My PHP shared object compiles just fine, and works perfectly.

The main problem is after I run my make, I'll go to the sapi/cli directory,
and the php file in this directory is a shell script, not a binary.

# Generated by ltmain.sh - GNU libtool 1.5.20 (1.1220.2.287 2005/08/31 18:54:15)
#
# The sapi/cli/php program cannot be directly executed until all the libtool
# libraries that it depends on are installed.
#
# This wrapper script should never be moved out of the build directory.
# If it is, it will not operate correctly.


the shell script calls the php file located in the .libs file.

If I run either of these two files, they work fine, but i'm curious why it doesn't build the binary.

The libtool installed is the one that comes with RHEL ES3, but I've built the latest version.
It turns out that PHP uses its own version of libtool, seperate from the systems...

my configure script is as follows:

./configure --with-apxs=/usr/local/apache/bin/apxs --with-oracle=/opt/oracle --with-oci8=/opt/oracle --with-zlib=/usr --enable-ftp --without-mysql --enable-sigchild --with-magickwand=/usr/local --with-ldap --with-java=/opt/java --enable-ftp --disable-debug --enable-inline-optimization --enable-memory-limit --with-pcre-regex --with-xsl --enable-libxml2 --enable-xml --enable-dom --with-libxml-dir=/usr --with-pear --with-pcre-regex

I've removed options, and tried recompiling, and I've noticed the issue seems to be related to
the xml options located at the end of the configure line.

If I remove any references to xml, PHP will compile cleanly, and a cli binary file will be built.
When I add the xml options, it still builds, but won't build the cli binary.

I'm using an RPM of libxml2, and libxml2-devel that I've built from srpms.


Any and all help would be appreciated.
Thanks,
John.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users