Jump to content


This topic is now archived and is closed to further replies.


phpMyAdmin - I'm Stumped

Recommended Posts

I'm at my wits end. Here's my tale of woe:

1) I'm running Windows 2003 Server/IIS6. (Let's try to avoid religious dicussions about running Windows instead of Linux - I need support for ASP.net 2.0, and Mono ain't there yet.)

2) I installed PHP 5.12 and have verified that it's working.

3) I installed Active Perl and MySQL 5.0, and verified that the mysql service is running.

4) I then installed phpMyAdmin, and ran the setup script. This i where my problem starts.

5) The PHP, Perl, and MySql folders are all in the windows system path.

6) I copied the file LIBMYSQL.DLL to both the \Windows\system and \Windows\system32 folders (despite the fact that the path setting should have been enough).

7) In php.ini, I have set the php extension path, and verified via phpinfo() that php is looking in that path for extensions via phpinfo() .

8) In php.ini, I have uncommented most of the extensions (including both php_msql.dll AND php_mysqli.dll).

9) I've verified through phpinfo() that php is using the php.ini file in the appropriate location.

Depite all of the above, when I run phpMyAdmin I get the following error:

"Cannot load MySQL extension, please check PHP Configuration"

I've done everything I thought I needed to do, and I've been searching high and low for a solution.

Can anyone help?

Share this post

Link to post
Share on other sites
here are some thigns i found were important...
Just check that they don't apply to you (for starters).
in the php.ini:
; Directory in which the loadable extensions (modules) reside.
extension_dir = "C:\Program Files\Apache Group\Apache2\php\extensions\"

Quotes are very important and the extensions folder MUST have a "\" at the end of it!!! otherwise it definatly will not work.

Make sure your server info (thats specific to you) is filled out in the phpmyAdmin dir you installed to.
The file is called config.inc.php.

These may be basic checks... but it's worth double checking.

Share this post

Link to post
Share on other sites


Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.