Jump to content


Photo

need some help


  • Please log in to reply
5 replies to this topic

#1 agima

agima
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 23 August 2003 - 02:55 PM

k im after setting up a web/file server

im using windows XP home edition and ive got a zoom adsl x4 modem/gateway/router all in 1 :)

ive downloaded apache and installed it and tested it out locally
eg:
http://localhost

and the apache welcome page pops up ok so far lol

i then went to www.dyndns.com and made an account for myself
and downloaded one of the client update software cos ive got a dynamic ip address

the ip/name i made is agima.dyndns.org

i havent change any of the files that came with apache and it works locally
now wot im after is how do i get it to host my server so ppl can view/download from agima.dyndns.org in other words i need my server online not just locally

im totaly new to this ive done a search on the board but cant understand alot of it lol


any help!!!

Thanks

Agima :)

#2 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 23 August 2003 - 10:16 PM

these will be found in your Allow from and Deny from lines within Directory directives in the apache configuration file. i was able to get to your address, but it is asking for a password. to remove the password, check, again, your Directory directive for Auth* type directives and remove them.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#3 agima

agima
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 23 August 2003 - 10:41 PM

Thanks effigy will have a look and see wot i can find



Thanks

Agima :shock:

#4 agima

agima
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 24 August 2003 - 09:12 AM

ok ive had a bit more of a play about still cant get it to work
also the user/password was my modem lol for some reason ppl would have had access to my modem cos i got the same as you effigy

a box popped up asking for username/password and i entered my modems user/pass and got into my modem setup page :)

i think the problem is with my modem it has NAT/NAPT also options for virtual servers DMZ,DNS and few other things but im not sure wot to set them up like

also not sure if i need these files but i cant find .htaccess/.htpassword ive seen a few ppl talk about them

anyway ill keep playing about and see wot i can do


Thanks
Agima :)

#5 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 24 August 2003 - 03:03 PM

in your modem\'s setup, go to the ports page where you tell it to open port 80 and point it to an internal ip, that being the ip of your machine. after the changes you\'ll probably have to restart it.

.htaccess files are placed in individual directories to control settings. personally, i prefer to place all of the information in the httpd.conf and not use these.

.htpassword files, i think, (this information can be used in the main config as well) are used to restrict access to certain areas of your site, requiring a username/password. you may or may not need them.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/

#6 agima

agima
  • New Members
  • Pip
  • Newbie
  • 4 posts

Posted 25 August 2003 - 09:00 PM

:D Thanks for ur help effigy i finaly got it working lol

I figured how to set my router up then found it was Norton Internet Security firwall that was the problem :wink:


Thanks

Agima :shock:




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users