Jump to content

Archived

This topic is now archived and is closed to further replies.

rayf

Server does not run php files

Recommended Posts

Hi,
My system is an i686 linux machine (Debian)
Apache is version 2.2.2
php is version 5.1.2

I have enabled fastcgi, mysql

When I point to a .html file is shows and the php parts mostly work (end of php usually shows as text)
When I point to a .php file I get the error message:

"The requested URL /php-fastcgi/php5-fcgi/hello.php was not found on this server."

All attempts to put the hello.php file in different directories has so far failed.

Any help/suggestions on how to get the Apache server to process .php files would be much appreciated.

Thanks,

RF

Share this post


Link to post
Share on other sites
[!--quoteo(post=372793:date=May 9 2006, 07:21 PM:name=rayf)--][div class=\'quotetop\']QUOTE(rayf @ May 9 2006, 07:21 PM) [snapback]372793[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Hi,
My system is an i686 linux machine (Debian)
Apache is version 2.2.2
php is version 5.1.2

I have enabled fastcgi, mysql

When I point to a .html file is shows and the php parts mostly work (end of php usually shows as text)
When I point to a .php file I get the error message:

"The requested URL /php-fastcgi/php5-fcgi/hello.php was not found on this server."

All attempts to put the hello.php file in different directories has so far failed.

Any help/suggestions on how to get the Apache server to process .php files would be much appreciated.

Thanks,

RF
[/quote]

Follow Up:

I have gotten the browser to recognize and run php file well now doing two things:

a) remove the two lines that referenced fast-cgi from httpd.conf:

"AddType application/x-httpd-fastphp .php
Action application/x-httpd-fastphp /php-fastcgi/php5-fcgi"

b) made this change in php.ini:

open_basedir = "/usr/local/apache2/htdocs" (the default php document dir)

I never did find out how to satisfy the path or change the path fast-cgi was looking for. but now the browser can access and process php files OK.

RF
[img src=\"style_emoticons/[#EMO_DIR#]/smile.gif\" style=\"vertical-align:middle\" emoid=\":smile:\" border=\"0\" alt=\"smile.gif\" /]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.