Jump to content


Photo

DWMX/PHP4.3/Apache -no server error messages?


  • Please log in to reply
2 replies to this topic

#1 mgm_03

mgm_03
  • Members
  • PipPipPip
  • Advanced Member
  • 49 posts
  • LocationFort Worth, TX

Posted 29 August 2003 - 06:16 AM

First, I am NOT using DWMX to do any coding...I am using Code View only and entering it all in manually. However, I do use Preview in Browser to see if the page works. If there\'s one thing wrong (e.g. division by zero) the page will be blank. BTW, I\'m using Mac OS10.2 and using http://localhost/mysite/somefile.php

My friend is using Apache/PHP4.3, DW 4.0, on WinXP. When he loads a PHP page that has something wrong(e.g. division by zero), he gets an error message from Apache telling what is wrong and on what line of code.

I\'m debugging in the dark it seems...any ideas? Error messages would be so helpful... Is there a better way?

Thanks in advance!!
Guru?...in my dreams!
Sorry Everybody

----------------------

#2 akitchin

akitchin
  • Staff Alumni
  • Advanced Member
  • 2,516 posts
  • LocationCalgary, AB, Canada

Posted 29 August 2003 - 09:09 AM

ok, well if it\'s a problem with debugging, it\'s likely that dreamweaver isn\'t the problem, if you\'re entering all your own code. it\'s likely the php.ini error_reporting setting or something. check that first.

#3 mgm_03

mgm_03
  • Members
  • PipPipPip
  • Advanced Member
  • 49 posts
  • LocationFort Worth, TX

Posted 29 August 2003 - 02:28 PM

thanks....I went to my php.ini file and found this:

; - display_errors = Off [Security]
; With this directive set to off, errors that occur during the execution of
; scripts will no longer be displayed as a part of the script output, and thus,
; will no longer be exposed to remote users. With some errors, the error message
; content may expose information about your script, web server, or database
; server that may be exploitable for hacking. Production sites should have this
; directive set to off.

I am guessing that I need to change Off to On, uncomment the line and re-start Apache....yes?
Guru?...in my dreams!
Sorry Everybody

----------------------




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users