Jump to content

Archived

This topic is now archived and is closed to further replies.

godman123

*SOLVED* smtp_port

Recommended Posts

I'm having problems testing a mail script on my localhost. When my form takes me to my PHP page, I get this error:

[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]Warning: mail() [function.mail]: Failed to connect to mailserver at "localhost" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in C:\wamp\www\sykotics\quotesend.php on line 76[/quote]

I've checked the php.ini, and all I can find is STMP = locahost. I tried adding stmp_port = 25, but no luck. I also tried ini_set("smtp_port","25"); but no luck as well. Any suggestions?

Share this post


Link to post
Share on other sites
The problem is you dont have an SMTP server installed for localhost. Now what you need to do is setup PHP to use an SMPT server in order for emails to be sent. Usually your ISP will have one available for its customers to send emails, an SMTP address is usually like this: [b]smtp.hostname.com[/b] change hostname.com to the actuall hostname for the SMTP server you are going to use or find a public SMTP server.

You shouldn't have to change the port number, as SMTP servers run via port 25 by defualt.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.