Jump to content

Archived

This topic is now archived and is closed to further replies.

liviniseasy

Warning: Cannot modify header information - headers already sent by

Recommended Posts

Hello everybody,

I know what you are thinking right now. "Here comes another idiot who didn't bother to search for the solution in the forum".

Actually I've been searching the web for the solution. I know it's a white space at the end of the begining of the file. The thing is I've downloaded lylina and pligg from sourceforge. And both should not have this white space code inserted.

I've even check all the php files for whitespaces. It's driving me cuckoo. As I have been trying to solve this problem for 2 weeks now. This is the first time I'm posting after scouring the internet for tips.


I'm using Apache 2.2, PHP 5.1.4, Mysql 5.0.1, XP, Firefox, IE 6. Please help me before I destroy my monitor due to my rage.

I left you now with the error I get from lylina.


Notice: Undefined index: title in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\fetch.php on line 80

Notice: Undefined index: logout in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\inc\auth.php on line 63

Notice: Undefined index: u in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\inc\auth.php on line 65

Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\fetch.php:80) in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\inc\common.php on line 164

Notice: Undefined variable: version in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\inc\common.php on line 165

Warning: Cannot modify header information - headers already sent by (output started at C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\fetch.php:80) in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\lylina\inc\common.php on line 165


cheers,
brad


Share this post


Link to post
Share on other sites
you should check for the undefined indices error. those are the outputs that caused the header error, not white spaces. :)

Share this post


Link to post
Share on other sites
I suspect it's because the header problem that cause the information unable to be written to the cookies. Which cause this undefine index.


take this error from pligg for instance.

Notice: Undefined index: template in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\pligg\config.php on line 91

Notice: Undefined index: search in C:\Program Files\Apache Software Foundation\Apache2.2\htdocs\pligg\index.php on line 28

config.php line 91: $thetemp = $_COOKIE['template'];

index.php line 28: $main_smarty->assign('searchtext', htmlspecialchars($_REQUEST['search']));




Share this post


Link to post
Share on other sites
Please note these are [b]not errors[/b]. They are [b]notices[/b] [warnings]. You can either fix the code by pre-defining any of those undefined items or you can reduce the error_reporting level so the warnings no longer appear - either will stop output to the browser which is what generates the header error.

Share this post


Link to post
Share on other sites
yup they're notices. try to reduce the error reporting level first and see if that would take care of the header warning.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.