Jump to content

Archived

This topic is now archived and is closed to further replies.

veerendra

PHP with Drupal

Recommended Posts

Hi all , I am having problems with Drupal frame work , Its asking me to enable mbstring . and I am having proeblem with PHP compilation , does anyone have the compiled version compatble to Drupal framework. If anyone have the same experience please share with me.

 

Thanks in adavance for your help.

Share this post


Link to post
Share on other sites

You need to go into your php.ini file and enable mb_string. If you don't have access to the php.ini file, and you are on an apache server, you can set this in your .htaccess file. Though I believe these settings are already made in the drupal pre-installed .htaccess file.

Share this post


Link to post
Share on other sites

Hi I tried putting the same entry in php.ini. No luck.

BTW I am using PHP version 5.2.6 . and I found in the PHP site that I need to recompile it with --enable-mbstring option. I am doing that and I am getting the fatal error. 

Share this post


Link to post
Share on other sites

make sure you are not running any other php program, like wamp, zend, etc. I was having simular problems, and what i did was got rid of zend and reinstalled wamp, and walla, it worked.

 

Most of those programs (if you have any other php related program) have the same php.ini folders and set themselves to be default when installed. So it screws with a lot of the functionality and loading of extensions.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.