Jump to content


Photo

Help!! I cannot INSERT INTO queries with odbc_exec


  • Please log in to reply
2 replies to this topic

#1 gaorellana

gaorellana
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 05 September 2006 - 04:04 PM

I am newbie with php, and I am using Win XP and IIS and my web server is in the localhost.

about read only attribute I did check on MS Access File>DataBase Properties in the General tab and the Attributes group is disabled (light grayed) but I acn see the check read only unchecked.

Also if I check the attributes outside from Access i.e. Windows Explorer the attribute flag readonly in unchecked too.

I post a check list of what I did.

1.create a MS Access Database (blank database) from the MS Access task pane.

2.locate the database outside the root path of the web folder.
My root path for web is c:\inetpub\wwwroot\mysite and the folder for the db is in c:\inetpub\wwwroot\mysite_db

3.I created a SystemDSN and give it the user and admin in advanced options of the ODBC Manager.

4.Wrote this code:

$val = array(); 
$con=odbc_connect("mySystemDSN","Admin","a_password"); 
$sql="exec user_A 'pepe', 'pepe','123456','pepe@pipo.pp','127.0.0.1','123456',0"; 
$rs = odbc_exec($con, $sql); 
odbc_free_result ( $rs ); 
odbc_close( $con );


First I used to login with blank admin and pwd. Then I attached the account Admin of the Access database a paswword. I still get the same ODBC error:

Warning: odbc_exec() [function.odbc-exec]: SQL error: [Microsoft][ODBC Microsoft Access Driver] Operation must use an updateable query., SQL state S1000 in SQLExecDirect

I still didn't get an idea of what is going on.
thanks in advance

#2 argoSquirrel

argoSquirrel
  • Members
  • PipPipPip
  • Advanced Member
  • 36 posts

Posted 05 September 2006 - 08:00 PM

http://www.phpbb.com...ic.php?t=66572.

http://www.zend.com/...=1&anc=0&view=1

Something about IUSR in XP i think.

#3 gaorellana

gaorellana
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 07 September 2006 - 01:50 AM

thanks argoSquirrel. Yes you are right! that was the problem.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users