Jump to content


Photo

What's the REAL story on register_globals?


  • Please log in to reply
6 replies to this topic

#1 Moron

Moron
  • Members
  • PipPipPip
  • Advanced Member
  • 368 posts

Posted 08 September 2006 - 01:36 PM

Okay, my script works but I get this warning:

Warning: Unknown: Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively.
in Unknown on line 0


In my php.ini file, I have these settings:

register_globals = On

session.bug_compat_42 = Off
session.bug_compat_warn = Off

This is on our internal Intranet, so security isn't a big deal. Technically, all info obtained in this script is public information, anyway.

So my question is...

How do I turh this annoying message off? Security isn't that big a deal here. I also ran phpinfo and confirmed that I'm editing the correct php.ini file.

Anybody?



#2 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 08 September 2006 - 01:41 PM

Did you restart the server when you changed those settings that was described in the warning.

#3 Moron

Moron
  • Members
  • PipPipPip
  • Advanced Member
  • 368 posts

Posted 08 September 2006 - 02:03 PM

Did you restart the server when you changed those settings that was described in the warning.


No, but I wondered about that. Is there a service I can restart instead or what about the Default Web Site?



#4 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 08 September 2006 - 02:05 PM

No, you must restart the server (not the hardware, but the software - eg (Apache, IIS or whate ever your server software is) in order for the new settings to be vailable. If you have Apache or IIS it just restart the service.

#5 Moron

Moron
  • Members
  • PipPipPip
  • Advanced Member
  • 368 posts

Posted 08 September 2006 - 02:09 PM

No, you must restart the server (not the hardware, but the software - eg (Apache, IIS or whate ever your server software is) in order for the new settings to be vailable. If you have Apache or IIS it just restart the service.


I see. Yeah, one of the guys here just suggested restarting IIS.

Thanks!



#6 Moron

Moron
  • Members
  • PipPipPip
  • Advanced Member
  • 368 posts

Posted 08 September 2006 - 02:35 PM

I figured it out. I had a variable that was redundant.


#7 Jenk

Jenk
  • Members
  • PipPipPip
  • Advanced Member
  • 778 posts

Posted 08 September 2006 - 04:45 PM

you also have E_STRICT warnings on.




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users