Jump to content

I need some help with php7 apache and mpm please


Recommended Posts

I am trying to get mpm with php7 going I have apache in worker mode now and in my apache.conf I have this

<IfModule mod_fastcgi.c>
        AddHandler php7-fcgi .php
        Action php7-fcgi /php7-fcgi
        Alias /php7-fcgi /usr/lib/cgi-bin/php7-fcgi
        FastCgiExternalServer /usr/lib/cgi-bin/php7-fcgi -socket /var/run/php/php7.0-fpm.sock -pass-header Authorization
</IfModule>

when I load a page it says

Forbidden

You don't have permission to access /php7-fcgi/test.php on this server.

 

Its following the alias path and im not sure what this is do I have to set it manually to the absolute path for each virtual host? is there a way I can make it work across the board?

 

Thanks

Link to comment
Share on other sites

I added this to the apache.conf

    <Directory /usr/lib/cgi-bin>
        Require all granted
    </Directory>

and I think that gets me a bit further but now it sits there for a long time and gives a 500 error in the apache error log I see

[Thu Aug 11 07:45:13.043220 2016] [fastcgi:error] [pid 11579:tid 139675982276352] [client 71.1.15.53:50752] FastCGI: comm with server "/usr/lib/cgi-bin/php7-fcgi" aborted: idle timeout (30 sec)
[Thu Aug 11 07:45:13.043247 2016] [fastcgi:error] [pid 11579:tid 139675982276352] [client 71.1.15.53:50752] FastCGI: incomplete headers (0 bytes) received from server "/usr/lib/cgi-bin/php7-fcgi"

not sure what to do now

Link to comment
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.