Jump to content
Sign in to follow this  
Freid001

Symphony & Nginx 500 error

Recommended Posts

Hi, 

 

I've recently been trying to learn more about VM's and vagrant, i'm also relatively new to Nginx as most development I have done in the passed has been on Apache.  

 

Anyway, I'm trying to setup a new Symfony project on my local under a workspace directory, within this directory I have several other projects too. 

 

I am able to run composer install and install the framework. I can go to the following endpoint: http://workspace.dev/symfony/web/app.php and see the "Welcome to symfony 3.2.2" page. However when I create a new route such as /test: 

/**
 * @Route("/test", name="test")
 */
public function testAction(Request $request)
{
    die('Hello world, welcome to the test page!');
}

and then go to: http://workspace.dev/symfony/web/app.php/test I get a Nginx 500 error. 

 

I'm not sure what I should do to resolve the issue or if I have missed something in the setup. 

 

I don't think this is a routing or .htaccess issue as it is is a blank install and i'm using: Sensio\Bundle\FrameworkExtraBundle\Configuration\Route

 

I though maybe I need to setup a new vhost for the project like: project.dev/test which points to > http://workspace.dev/symfony/web/app.php

but had no success. 

 

Would be really grateful of any help :)

 

I'm using puphpet to generate my vagrant files etc. the config is like so:

vagrantfile:
    target: local
    vm:
        provider:
            local:
                box: puphpet/ubuntu1404-x64
                box_url: puphpet/ubuntu1404-x64
                box_version: '0'
                chosen_virtualizer: virtualbox
                virtualizers:
                    virtualbox:
                        modifyvm:
                            natdnshostresolver1: false
                        showgui: 0
                    vmware:
                        numvcpus: 1
                    parallels:
                        linked_clone: 0
                        check_guest_tools: 0
                        update_guest_tools: 0
                machines:
                    vflm_75yfxsvwnabf:
                        id: machine1
                        hostname: machine1.puphpet
                        network:
                            private_network: 192.168.56.101
                            forwarded_port:
                                vflmnfp_8bx6f11n3o9p:
                                    host: '7373'
                                    guest: '22'
                        memory: '512'
                        cpus: '1'
        provision:
            puppet:
                manifests_path: puphpet/puppet/manifests
                module_path:
                    - puphpet/puppet/modules
                    - puphpet/puppet/manifests
                options:
                    - '--verbose'
                    - '--hiera_config /vagrant/puphpet/puppet/hiera.yaml'
        synced_folder:
            vflsf_53kwyzt6imrw:
                source: ./
                target: /var/www
                sync_type: nfs
                smb:
                    smb_host: ''
                    smb_username: ''
                    smb_password: ''
                    mount_options:
                        dir_mode: '0775'
                        file_mode: '0664'
                rsync:
                    args:
                        - '--verbose'
                        - '--archive'
                        - '-z'
                    exclude:
                        - .vagrant/
                        - .git/
                    auto: 'true'
                owner: www-data
                group: www-data
        usable_port_range:
            start: 10200
            stop: 10500
        post_up_message: ''
    ssh:
        host: 'false'
        port: 'false'
        private_key_path: 'false'
        username: vagrant
        guest_port: 'false'
        keep_alive: '1'
        forward_agent: 'false'
        forward_x11: 'false'
        shell: 'bash -l'
        insert_key: 'false'
    vagrant:
        host: detect
    proxy:
        http: ''
        https: ''
        ftp: ''
        no_proxy: ''
server:
    install: '1'
    packages:
        - vim
users_groups:
    install: '1'
    groups: {  }
    users: {  }
locale:
    install: '1'
    settings:
        default_locale: en_US.UTF-8
        locales:
            - en_GB.UTF-8
            - en_US.UTF-8
        timezone: UTC
firewall:
    install: '1'
    rules: {  }
cron:
    install: '1'
    jobs: {  }
nginx:
    install: '1'
    settings:
        version: present
        default_vhost: 1
        proxy_buffers: '4 256k'
        proxy_buffer_size: 128k
        proxy_connect_timeout: 600s
        proxy_send_timeout: 600s
        proxy_read_timeout: 600s
        names_hash_bucket_size: 128
    upstreams: {  }
    vhosts:
        nxv_74ybirqpo6y6:
            server_name: workspace.dev
            www_root: /var/www/workspace
            listen_port: '80'
            client_max_body_size: 1m
            ssl: '0'
            ssl_cert: ''
            ssl_key: ''
            ssl_port: '443'
            ssl_protocols: ''
            ssl_ciphers: ''
            rewrite_to_https: '1'
            spdy: '1'
            locations:
                nxvl_8z3jl4fqoihu:
                    www_root: ''
                    location: /
                    index_files:
                        - index.html
                        - index.htm
                        - index.php
                    try_files:
                        - $uri
                        - $uri/
                        - /index.php$is_args$args
                    fastcgi: ''
                    fastcgi_index: ''
                    fastcgi_split_path: ''
                    proxy: ''
                    proxy_redirect: ''
                nxvl_v3elxlm2ee8t:
                    www_root: ''
                    location: '~ \.php$'
                    try_files:
                        - $uri
                        - $uri/
                        - /index.php$is_args$args
                    fastcgi: '127.0.0.1:9000'
                    fastcgi_index: index.php
                    fastcgi_split_path: '^(.+\.php)(/.*)$'
                    fast_cgi_params_extra:
                        - 'SCRIPT_FILENAME $request_filename'
                        - 'APP_ENV dev'
                    set:
                        - '$path_info $fastcgi_path_info'
                    proxy: ''
                    proxy_redirect: ''
    proxies: {  }
apache:
    install: '0'
    settings:
        version: 2.4
        user: www-data
        group: www-data
        default_vhost: true
        manage_user: false
        manage_group: false
        sendfile: 0
    modules:
        - proxy_fcgi
        - rewrite
    vhosts:
        av_4infpibvguio:
            servername: awesome.dev
            serveraliases:
                - www.awesome.dev
            docroot: /var/www/awesome
            port: '80'
            setenv:
                - 'APP_ENV dev'
            setenvif:
                - 'Authorization "(.*)" HTTP_AUTHORIZATION=$1'
            custom_fragment: ''
            ssl: '0'
            ssl_cert: ''
            ssl_key: ''
            ssl_chain: ''
            ssl_certs_dir: ''
            ssl_protocol: ''
            ssl_cipher: ''
            directories:
                avd_b11z3wfwne08:
                    path: /var/www/awesome
                    options:
                        - Indexes
                        - FollowSymlinks
                        - MultiViews
                    allow_override:
                        - All
                    require:
                        - 'all granted'
                    custom_fragment: ''
                    files_match:
                        avdfm_hvzzj66xcvle:
                            path: \.php$
                            sethandler: 'proxy:fcgi://127.0.0.1:9000'
                            custom_fragment: ''
                            provider: filesmatch
                    provider: directory
letsencrypt:
    install: '1'
    settings:
        email: ''
    domains: {  }
php:
    install: '1'
    settings:
        version: '7.0'
    modules:
        php:
            - cli
            - intl
            - xml
        pear: {  }
        pecl: {  }
    ini:
        display_errors: 'On'
        error_reporting: '-1'
        session.save_path: /var/lib/php/session
        date.timezone: UTC
    fpm_ini:
        error_log: /var/log/php-fpm.log
    fpm_pools:
        phpfp_mbsmnwlxru02:
            ini:
                prefix: www
                listen: '127.0.0.1:9000'
                security.limit_extensions: .php
                user: www-user
                group: www-data
    composer: '1'
    composer_home: ''
xdebug:
    install: '0'
    settings:
        xdebug.default_enable: '0'
        xdebug.remote_autostart: '0'
        xdebug.remote_connect_back: '0'
        xdebug.remote_enable: '0'
        xdebug.remote_handler: dbgp
        xdebug.remote_port: '9000'
blackfire:
    install: '0'
    settings:
        server_id: ''
        server_token: ''
        agent:
            http_proxy: ''
            https_proxy: ''
            log_file: stderr
            log_level: '1'
        php:
            agent_timeout: '0.25'
            log_file: ''
            log_level: '1'
xhprof:
    install: '0'
wpcli:
    install: '0'
    version: v0.24.1
drush:
    install: '0'
    version: 8.0.5
ruby:
    install: '1'
    versions:
        rv_p3peyopuq3qe:
            default: '1'
            bundler: '1'
            version: 2.3.1
            gems:
                - deep_merge@1.0.1
                - activesupport@4.2.6
                - vine@0.2
python:
    install: '1'
    packages: {  }
    versions: {  }
nodejs:
    install: '1'
    settings:
        version: '6'
    npm_packages: {  }
hhvm:
    install: '0'
    composer: '1'
    composer_home: ''
    settings: {  }
    server_ini:
        hhvm.server.host: 127.0.0.1
        hhvm.server.port: '9000'
        hhvm.log.use_log_file: '1'
        hhvm.log.file: /var/log/hhvm/error.log
    php_ini:
        display_errors: 'On'
        error_reporting: '-1'
        date.timezone: UTC
mariadb:
    install: '0'
    settings:
        version: '10.1'
        root_password: '123'
        override_options: {  }
    adminer: 0
    users:
        mariadbnu_pc6gjoy99feb:
            name: dbuser
            password: '123'
    databases:
        mariadbnd_wt6ozsihg8us:
            name: dbname
            sql: ''
    grants:
        mariadbng_nc5i0ukkwapg:
            user: dbuser
            table: '*.*'
            privileges:
                - ALL
mysql:
    install: '1'
    settings:
        version: '5.7'
        root_password: '123'
        override_options: {  }
    adminer: 0
    users:
        mysqlnu_mqqy0asimbr1:
            name: dbuser
            password: '123'
    databases:
        mysqlnd_99t2ic6cge0q:
            name: dbname
            sql: ''
    grants:
        mysqlng_imc2gpk71d6v:
            user: dbuser
            table: '*.*'
            privileges:
                - ALL
postgresql:
    install: '0'
    settings:
        global:
            encoding: UTF8
            version: '9.6'
        server:
            postgres_password: '123'
    databases: {  }
    users: {  }
    grants: {  }
    adminer: 0
mongodb:
    install: '0'
    settings:
        bind_ip: 127.0.0.1
        port: '27017'
    globals:
        version: 2.6.0
    databases: {  }
redis:
    install: '0'
    settings:
        port: '6379'
sqlite:
    install: '0'
    adminer: 0
    databases: {  }
mailhog:
    install: '0'
    settings:
        smtp_ip: 0.0.0.0
        smtp_port: 1025
        http_ip: 0.0.0.0
        http_port: '8025'
        path: /usr/local/bin/mailhog
beanstalkd:
    install: '0'
    settings:
        listenaddress: 0.0.0.0
        listenport: '11300'
        maxjobsize: '65535'
        maxconnections: '1024'
        binlogdir: /var/lib/beanstalkd/binlog
        binlogfsync: null
        binlogsize: '10485760'
    beanstalk_console: 0
rabbitmq:
    install: '0'
    settings:
        port: '5672'
    users: {  }
    vhosts: {  }
    plugins: {  }
elastic_search:
    install: '0'
    settings:
        version: 2.3.1
        java_install: true
    instances:
        esi_tu0viqar5x3i:
            name: es-01
solr:
    install: '0'
    settings:
        version: 5.5.2
        port: '8984'


Edited by Freid001

Share this post


Link to post
Share on other sites

Both nginx and Symfony produce logs:

  • nginx: /var/log/nginx/
  • Symfony: [your project directory]/var/logs/dev.log or prod.log

If you're able to run the default page, I think that Nginx works, and the problem is on the framework side. Routing problems are generally reported in Symfony log files and they should give you some clue. For development purpose, use app_dev.php file instead of app.php. In the development mode, Symfony shows detailed information about exceptions directly in the browser, and you have an access to the profiler, too.

Share this post


Link to post
Share on other sites

Hi, Thanks for commenting. 

 

Nginx - error log:

 2017/01/15 14:05:44 [error] 1826#1826: *3 rewrite or internal redirection cycle while internally redirecting to "/index.php", client: 192.168.56.1, server: workspace.dev, request: "GET /      favicon.ico HTTP/1.1", host: "workspace.dev", referrer: "http://workspace.dev/symfony/web/app.php/test"
 2017/01/15 14:07:03 [error] 1826#1826: *4 rewrite or internal redirection cycle while internally redirecting to "/index.php", client: 192.168.56.1, server: workspace.dev, request: "GET /      symfony/web/app_dev.php/test HTTP/1.1", host: "workspace.dev"
 2017/01/15 14:07:03 [error] 1826#1826: *5 rewrite or internal redirection cycle while internally redirecting to "/index.php", client: 192.168.56.1, server: workspace.dev, request: "GET /      favicon.ico HTTP/1.1", host: "workspace.dev", referrer: "http://workspace.dev/symfony/web/app_dev.php/test"

Nginx access log: 

 192.168.56.1 - - [15/Jan/2017:14:05:44 +0000] "GET /symfony/web/app.php/test HTTP/1.1" 500 595 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.0.    2883.87 Safari/537.36"
 192.168.56.1 - - [15/Jan/2017:14:05:44 +0000] "GET /favicon.ico HTTP/1.1" 500 595 "http://workspace.dev/symfony/web/app.php/test" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36      (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"
 192.168.56.1 - - [15/Jan/2017:14:07:03 +0000] "GET /symfony/web/app_dev.php/test HTTP/1.1" 500 595 "-" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/55.  0.2883.87 Safari/537.36"
 192.168.56.1 - - [15/Jan/2017:14:07:03 +0000] "GET /favicon.ico HTTP/1.1" 500 595 "http://workspace.dev/symfony/web/app_dev.php/test" "Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36  (KHTML, like Gecko) Chrome/55.0.2883.87 Safari/537.36"

The Symphony log is empty.

 

Also when I try to run app_dev.php for the index page I get this error: An error occurred while loading the web debug toolbar (500: Internal Server Error) Do you want to open the profiler? I open the profiler and it does give a 500 error too. 

 

Thanks

Share this post


Link to post
Share on other sites

The Nginx config looks like this: 

server {
  listen                *:80;

  server_name           workspace.dev ;
  client_max_body_size 1m;

  root /var/www/workspace;
    index  index.html index.htm index.php;

  access_log            /var/log/nginx/nxv_74ybirqpo6y6.access.log;
  error_log             /var/log/nginx/nxv_74ybirqpo6y6.error.log;
  location ~ \.php$ {


    set $path_info $fastcgi_path_info;
    root  /var/www/workspace;
    fastcgi_index index.php;
    fastcgi_split_path_info ^(.+\.php)(/.*)$;
    try_files $uri $uri/ /index.php$is_args$args;
    include /etc/nginx/fastcgi_params;
    fastcgi_pass 127.0.0.1:9000;

    fastcgi_param SCRIPT_FILENAME $request_filename;
    fastcgi_param APP_ENV dev;

  }
  location / {


    root  /var/www/workspace;
    try_files $uri $uri/ /index.php$is_args$args;
     autoindex off;
    index  index.html index.htm index.php;


  }
  sendfile off;
}

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.