Jump to content

RhoVisions

New Members
  • Content Count

    8
  • Joined

  • Last visited

Community Reputation

0 Neutral

About RhoVisions

  • Rank
    Newbie

Profile Information

  • Gender
    Not Telling
  1. Thanks for the detailed feedback. I trust you're right; I must have mixed up which is the NAT and the host-only. As for why I have both, when I first created the VM, it had the NAT only, and I couldn't get it to connect to the internet through the host. Through googling, I found that the only way to both server locally and have it connect to internet through the host was with a NAT for serving and a host-only for the internet. If that's wrong, I'd love advice on how to get it working, as I wasn't able to find another way. Looking at the Vagrant boxes at work, they have the same setup. Following your instructions, seems like no matter what IP I change it to, atom is only listening on 127.0.0.1, which I think means it's the Atom package itself. I hope so, because after reading so many instructions and looking for advice, the fact that it fails because of the app is kind of nice to know. It makes me debate spending the money for PHPStorm, though there are Atom features I really like...
  2. I tried it with both remote_host and remote_connect_back, as different tutorials suggested each. And I confirmed by IP by checking phpinfo(). As the NAT is set to 192.168.56.102, i guess it kind of makes sense that the connecting IP is 56.1?
  3. I have 2 adapters setup, a NAT and a host-only.
  4. That's what I figured. Nothing listening on 9000.
  5. I'll move the changes over; thanks for letting me know. As for my settings, here's what I added, everything else left default (I can screenshot the full values if it's beneficial?) xdebug.remote_autostart = 1 xdebug.remote_log = /tmp/xdebug.log xdebug.remote_enable = 1 xdebug.remote_connect_back = 1 #xdebug.remote_host=192.168.56.1 xdebug.remote_port = 9000 xdebug.idekey = xdebug-atom Having looked around online and through the xdebug docs, I tried both a remote host ip as well as remote_connect_back.
  6. Thanks for the initial replies. Yes, I setup the xdebug values in php.ini, trying both the values in the Atom package docs and the SO answer. phpinfo() validates the values. According to the package doc, the idekey is xdebug-atom (I saw xdebug.atom in some posts as well), so I tried both values; neither worked. I'm not sure how to check the firewall. I checked netstat -a -b and I didn't see anything using the port, but should I be checking the Windows host port 9000 or the Ubuntu port? The xdebug ini only had the link to the xdebug so file; no settings in there. Making the changes in php.ini did reflect in phpinfo() though.
  7. I wasn't sure if this better belonged here or the editors forum, so if this should be elsewhere, I hope an admin can move it for me. I finally decided to start using Xdebug, as I read up about it's great merits for debugging over just dumping out variables. Unfortunately, of course my forie into something new failed from the get go. I'm developing on an Ubuntu 14 VirtualBox, and looking at phpinfo, xdebug was already installed and setup, though none of the configs were in php.ini. As I develop on Atom, I found a StackOverflow answer on setting up xdebug and atom. Unfortunately, when I started using it, though after some problem solving I can get the debug pane to come up and says it's listening to my VM, adding a breakpoint doesn't actually pause my app; everything runs as if I did nothing. Unfortunately, I can't tell if I setup xdebug incorrect, if it's not working correctly, something's wrong with my Atom setup, or I'm just not understanding xdebug in general. I'm hoping someone more experienced can help me get on my feet for what looks like an awesome tool
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.