Jump to content

frenchpl

Members
  • Content Count

    22
  • Joined

  • Last visited

Community Reputation

0 Neutral

About frenchpl

  • Rank
    Member

Profile Information

  • Gender
    Not Telling
  1. Hi I am migrating my mysql database from windows xp to centos 6. I have the database up and running on the linux. However I cannot connect to it through firefox as I usually do on windows. I am pretty sure that my PHP scripts are OK and this is a configuration issue. Reading the error logs I find that it is trying to connect via /var/lib/mysql/mysql.sock and cannot find it [Thu Jan 26 08:14:19 2017] [error] [client ::1] PHP Warning: mysql_connect(): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) in /var/www/htdocs/HomeLogIn.php on line 87, referer: http://localhost/HomeLogIn.php The correct location is of course /var/run/mysqld/mysql.sock There is obviously a configuration file somewhere that is setting the wrong path info, however I cannot find it. /etc/my.cnf is correct as is /etc/php.ini to the best of my knowledge ------------------------------------------------ my.cnf [client] port=3306 socket = /var/run/mysqld/mysql.sock # SERVER SECTION [mysqld] # The TCP/IP Port the MySQL Server will listen on port=3306 socket = /var/run/mysqld/mysql.sock #Path to the database root datadir="/var/lib/mysql/mysql" -------------------------------- I checked the /etc/httpd content and that seemed OK too. Obviously I am missing one somewhere but where, any thoughts please? I tried restarting Mysql with no effect at all. In fact shutting down the machine and restarting it makes no difference either.
  2. Thank you Kicken that worked just fine Now I have another configuration problem I have to solve. My firefox will not connect to the mysql. Reading the error logs I find that it is trying to connect via /var/lib/mysql/mysql.sock and cannot find it The correct location is of course /var/lib/mysqld/mysql.sock There is obviously a configuration file somewhere that is using the wrong info, however I cannot find it. /etc/my.cnf is correct as is /etc/php.ini I checked the /etc/httpd content and that seemed OK too. Obviously I am missing one somewhere but where??
  3. Can someone assist me please. I am trying to shift my mysql database from windows xp to centos 6. On the windows I am running mysql 5.0.83 and using administrator 1.2.17 However on the linux I am running mysql 5.1.83 and trying to use workbench 6.3 I have backed up my database using the administrator This created a windows Backup.sql file. Trying to transfer this to linux and then restore it will not work. The workbench just will not see the file even if I rename it. My next trial was to open the backup file with Kwrite and then to copy and paste the content directly into a mysql terminal. This was successful on creating no only the database but all the tables. However the data for the tables was a different story. If there was a very limited number of rows of data it worked Anything over 10 rows gives me a mysql syntax error. Is there a way around this other than trying to edit a file with thousands of rows of data. I know there is a difference in the mysql proc table column numbers from 16 in the older version to 20 in the newer but I do not think that should make a difference here.
×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.