Jump to content


Photo

problem of localhost


  • Please log in to reply
6 replies to this topic

#1 begeiste

begeiste
  • Members
  • PipPip
  • Member
  • 19 posts

Posted 24 May 2006 - 09:14 PM

Installed and configured, I have created a folder 'webs' in the C:/webs, have another subfolder 'test' under webs folder, C:/webs/test/index.php. For some reasons I've got those errors when I tested.
In Firefox I've got this :

Forbidden
You don't have permission to access /php/php-cgi.exe/index.php on this server.

In IE I've got:You are not authorized to view this page
You might not have permission to view this directory or page using the credentials you supplied.

--------------------------------------------------------------------------------

If you believe you should be able to view this directory or page, please try to contact the Web site by using any e-mail address or phone number that may be listed on the localhost home page.

You can click Search to look for information on the Internet.

HTTP Error 403 - Forbidden
Internet Explorer

Can someone help me to explain what was it going on and how to make it worked? Thanks.

#2 hvle

hvle
  • Members
  • PipPipPip
  • Advanced Member
  • 667 posts
  • Locationmelbourne, Australia

Posted 25 May 2006 - 01:23 AM

I think you have done something wrong during setting up the http server.
you need to set the root document folder to whatever folder you wanted.
As for your error, it look like your root folder is /php/php-cgi.exe/ and because there is no such folder, browser return an unauthorized error.

regards
Life's too short for arguing.

#3 begeiste

begeiste
  • Members
  • PipPip
  • Member
  • 19 posts

Posted 25 May 2006 - 05:19 AM

[!--quoteo(post=376817:date=May 24 2006, 04:14 PM:name=begeiste)--][div class=\'quotetop\']QUOTE(begeiste @ May 24 2006, 04:14 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
Installed and configured, I have created a folder 'webs' in the C:/webs, have another subfolder 'test' under webs folder, C:/webs/test/index.php. For some reasons I've got those errors when I tested.
In Firefox I've got this :

Forbidden
You don't have permission to access /php/php-cgi.exe/index.php on this server.

In IE I've got:You are not authorized to view this page
You might not have permission to view this directory or page using the credentials you supplied.

--------------------------------------------------------------------------------

If you believe you should be able to view this directory or page, please try to contact the Web site by using any e-mail address or phone number that may be listed on the localhost home page.

You can click Search to look for information on the Internet.

HTTP Error 403 - Forbidden
Internet Explorer

Can someone help me to explain what was it going on and how to make it worked? Thanks.
[/quote]


#4 karthikeyan_coder

karthikeyan_coder
  • Members
  • PipPipPip
  • Advanced Member
  • 201 posts

Posted 25 May 2006 - 06:03 PM

/php/php-cgi.exe/index.php php-cgi.exe/index.php please check the settings of httpd.conf in apache folder.
www.karthi.us

#5 begeiste

begeiste
  • Members
  • PipPip
  • Member
  • 19 posts

Posted 25 May 2006 - 06:27 PM

[!--quoteo(post=377082:date=May 25 2006, 01:03 PM:name=Karthikeyan)--][div class=\'quotetop\']QUOTE(Karthikeyan @ May 25 2006, 01:03 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
/php/php-cgi.exe/index.php php-cgi.exe/index.php please check the settings of httpd.conf in apache folder.
[/quote]
[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]Sorry man, there is no such script " /php/php-cgi.exe/index.php " in the httpd.conf in apache folder, now whatelse should I look for?Thanks.[/quote]

#6 burhankhan

burhankhan
  • Members
  • PipPipPip
  • Advanced Member
  • 43 posts

Posted 26 May 2006 - 10:31 AM

in httpd.conf search "DocumentRoot" and set it to

DocumentRoot "C:/webs"

Then open this url: [a href=\"http://localhost/test/index.php\" target=\"_blank\"]http://localhost/test/index.php[/a]

#7 begeiste

begeiste
  • Members
  • PipPip
  • Member
  • 19 posts

Posted 26 May 2006 - 05:43 PM

[!--quoteo(post=377267:date=May 26 2006, 05:31 AM:name=burhankhan)--][div class=\'quotetop\']QUOTE(burhankhan @ May 26 2006, 05:31 AM) View Post[/div][div class=\'quotemain\'][!--quotec--]
in httpd.conf search "DocumentRoot" and set it to

DocumentRoot "C:/webs"

Then open this url: [a href=\"http://localhost/test/index.php\" target=\"_blank\"]http://localhost/test/index.php[/a]
[/quote]
[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]Thanks man![/quote]




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users