Jump to content

Archived

This topic is now archived and is closed to further replies.

ReVeR

Connecting php to mysql v 5

Recommended Posts

Hello.
I need to connect mysql to php, both are version 5s. I changed the extensions_dir in php.ini to correct path, i uncommented the extension=php_mysql.dll, but php still gives me:
[code]
Fatal error: Call to undefined function mysql_connect() in C:\Apache\Apache2\htdocs\test.php on line 8
[/code]
I think i forgot to move a dll from or to mysql direction, does anyone know what dll i am suppoused to move?
Thx

Share this post


Link to post
Share on other sites
Hello ReVeR,

When setting up my server I had similar problem, and I resolved it by adding

extension=php_mysqli.dll instead of extension=php_mysql.dll as php5 and MySQL5 use this instead, as mysqli i believe this to mean MySQL Improved and only works for later versions of PHP and MySQL.

You will also have to edit the MySQLi section of your php.ini file instead of the MySQL section:

See Example:

[MySQLi]

; Maximum number of links. -1 means no limit.
mysqli.max_links = -1

; Default port number for mysqli_connect(). If unset, mysqli_connect() will use
; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the
; compile-time value defined MYSQL_PORT (in that order). Win32 will only look
; at MYSQL_PORT.
mysqli.default_port = 3306

; Default socket name for local MySQL connects. If empty, uses the built-in
; MySQL defaults.
mysqli.default_socket =

; Default host for mysql_connect() (doesn't apply in safe mode).
mysqli.default_host = localhost

; Default user for mysql_connect() (doesn't apply in safe mode).
mysqli.default_user = root

; Default password for mysqli_connect() (doesn't apply in safe mode).
; Note that this is generally a *bad* idea to store passwords in this file.
; *Any* user with PHP access can run 'echo get_cfg_var("mysqli.default_pw")
; and reveal this password! And of course, any users with read access to this
; file will be able to reveal the password as well.
mysqli.default_pw =

; Allow or prevent reconnect
mysqli.reconnect = Off

[mSQL]
; Allow or prevent persistent links.
msql.allow_persistent = On

; Maximum number of persistent links. -1 means no limit.
msql.max_persistent = -1

; Maximum number of links (persistent+non persistent). -1 means no limit.
msql.max_links = -1

I hope this helps and solves your problem

Share this post


Link to post
Share on other sites
Please read my thread [a href=\"http://www.phpfreaks.com/forums/index.php?showtopic=87276\" target=\"_blank\"]here[/a]

Share this post


Link to post
Share on other sites
thx alot,. thats the file i forgot to move. sry that i didn;t find that thread b4 posting.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.