Jump to content

Archived

This topic is now archived and is closed to further replies.

volskid2002

new to apache

Recommended Posts

i installed apache, php, and mysql and everything is working fine for me except that other people cannot view my website. when i go to localhost everything show up fine!!! I have a linksys router that i have port 80 forwarded on so its open and here are some excerps from my httpd file:

 

#

# Listen: Allows you to bind Apache to specific IP addresses and/or

# ports, instead of the default. See also the <VirtualHost>

# directive.

#

#Listen 3000

#Listen 12.34.56.78:80

Listen 68.169.58.113:80

 

#

# Port: The port to which the standalone server listens.  Certain firewall

# products must be configured before Apache can listen to a specific port.

# Other running httpd servers will also interfere with this port.  Disable

# all firewall, security, and other services if you encounter problems.

# To help diagnose problems use the Windows NT command NETSTAT -a

#

Port 80

 

#

# ServerName allows you to set a host name which is sent back to clients for

# your server if it\'s different than the one the program would get (i.e., use

# \\\"www\\\" instead of the host\'s real name).

#

# Note: You cannot just invent host names and hope they work. The name you  

# define here must be a valid DNS name for your host. If you don\'t understand

# this, ask your network administrator.

# If your host doesn\'t have a registered DNS name, enter its IP address here.

# You will have to access it by its address (e.g., http://123.45.67.89/)

# anyway, and this will make redirections work in a sensible way.

#

# 127.0.0.1 is the TCP/IP local loop-back address, often named localhost. Your  

# machine always knows itself by this address. If you use Apache strictly for  

# local testing and development, you may use 127.0.0.1 as the server name.

#

ServerName 68.169.58.113:80

 

i think that about does it so can anyone figure out why no one can connect to my server. if my ISP blocks port 80 how can i change that so that others can view my site?

 

any help would be greatly appreciated!!!

Share this post


Link to post
Share on other sites

are you running windows or linux? again, check for any firewalls in the way. if your ISP blocks port 80, change it to 8080, for example.

Share this post


Link to post
Share on other sites

im running windows xp pro and i have all my firewalls disabled,b ut im not sure if my ISP blocks port 80 or not. if they do block it how do i change it to 8080 like you said?

Share this post


Link to post
Share on other sites

change your httpd.conf to the following (this is copied straight from mine, and it is working):

# Change this to Listen on specific IP addresses as shown below to  

# prevent Apache from glomming onto all bound IP addresses (0.0.0.0)

#

#Listen 12.34.56.78:80

Listen 80

Listen 8080

You don\'t need to specify your IP address in there since your server is presumably on an internal IP address anyway, your linksys is grabbing the external one.

Note: I use both 80 and 8080 because the 8080 is for the external connections, the 80 I use for the internal.

 

External users will then have to connect to http://(your external IP address):8080

The address you need to give them is the address of the router, not the address of your machine.

 

You might want to do an IPCONFIG and check what the address of your machine really is - the one quoted in your httpd doesn\'t look right for an internal address, so your server may be binding to the wrong IP.

 

Hope that helps!

 

D

 

***edit*** go to http://grc.com and use the port scanner there to see if port 80 is open or not (and any other ports too!!) D

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.