Jump to content

Archived

This topic is now archived and is closed to further replies.

Mutley

Dreamweaver adding spaces between each line

Recommended Posts

As the title says, I keep getting PHP scripts opening with an extra line between each line of code, it makes the script twice the length. However if I open it in Notepad, it looks fine, how it should be.

 

What's causing this and how do I fix it?

 

Thanks,

Nick.

Share this post


Link to post
Share on other sites

If you find out what's causing it, let me know, 'cos I want my code to be automatically shown double spaced  ;D

 

Actually, I'm after an editor that's shows double line height but only has single lines.

 

If people get what I mean.  At the moment I purposely add an extra line between each statement, I'm using

a PHP Optimizer on the server anyway, and I just find I can read code better with more space between each

line.

Share this post


Link to post
Share on other sites

Found how to repair the files but not fix it, it's to do with the format OS used (Windows/Linux/Apple).

 

In your code:

 

Find: (press Ctrl + m twice)

Replace With: (press Ctrl + m once)

 

And it will remove all the excessive lines! :D

Share this post


Link to post
Share on other sites

Im having this problem too and Im not happy about it. Its screwing up my php scripts.  Does someone know how to turn that crap off in DW CS3?

Share this post


Link to post
Share on other sites

I found another solution.

 

If you download the files in 'Binary' mode with your FTP, it removes the extra lines.

 

It seems when the file is edited in different applications and uploaded / downloaded. It adds these extra spaces. Binary mode fixed it for me.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.