Jump to content

Archived

This topic is now archived and is closed to further replies.

PichelM

cannot connect with with MySQL root user

Recommended Posts

I\'m really losing the will to live here. I\'m now into my 2nd installation of mySQL under OS X 10.2.8. My first install was removed using Marc Liyanage\'s removal script and did a nice and tidy job.

 

2nd install went fine, I managed to do a test connect using

I then went ahead and did (as recommended) the setting of the password for the root user via:

And now (just as before in the first install) I can\'t connect to the database using the root user. the following line

  • /usr/local/mysql/bin/mysql --user=root mysql

comes back with

ERROR 1045: Access denied for user: \'root@localhost\' (Using password: NO)

which suggests that I haven\'t set the password... but I have (see above)

 

Oddly enough, I can connect to mySQL using the mySQL user (standard in OS X 10.2) via:

but I can\'t really do anything as any attempt to create for example

  • mysql> INSERT INTO user VALUES(\'localhost\',\'root\',PASSWORD(\'some_pass\'),

-> \'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\',\'Y\');

results in ERROR 1046: No Database Selected

 

What am I doing wrong ? help !!!

 

PM

Share this post


Link to post
Share on other sites

try using the p switch:

 

/usr/local/mysql/bin/mysql --user=root mysql -p

 

you should get prompted for a password.

 

for the no databased selected error type use databasename; once you are connected, then attempt your insert.

Share this post


Link to post
Share on other sites

thanks effigy - think I\'m a step further now. running \'status\' in mysql now says I\'m logged in as root@localhost.

 

many thanks,

PM

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.