Jump to content

Archived

This topic is now archived and is closed to further replies.

karthikeyan_coder

how to send emails from localhost with mail()

Recommended Posts

i've tried to send emails from localhost. but its showing some error like... [quote]Warning: mail() [function.mail]: Failed to connect to mailserver at "192.168.110.30" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\wamp\www\mailsender.php on line 55[/quote]

actually in my php.ini file contains...

[mail function]
; For Win32 only.
SMTP = 192.168.110.30
smtp_port = 25

; For Win32 only.
sendmail_from = info@info.com


whats the problem???
im running apache under windowzxp box...


Thank you,
Karthi Keyan.

Share this post


Link to post
Share on other sites
You have to make sure you had a working mail server (SMTP).

Share this post


Link to post
Share on other sites
[quote author=hackerkts link=topic=99143.msg390290#msg390290 date=1151800132]
You have to make sure you had a working mail server (SMTP).
[/quote]

LOL i know its a SMTP mailserver prob... its not working.... i asked how to solve this.... i hope you never read this [quote]Warning: mail() [function.mail]: Failed to connect to mailserver at "192.168.110.30" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\wamp\www\mailsender.php on line 55[/quote]

[quote]Hackers must have a skill to solve probs... LOL[/quote]

Any one know? how to slove? Please help me...

Share this post


Link to post
Share on other sites
Does the SMTP server require authentication in order to send emails. if it does mail doesnt support this.

Share this post


Link to post
Share on other sites
[quote author=wildteen88 link=topic=99143.msg390429#msg390429 date=1151834976]
Does the SMTP server require authentication in order to send emails. if it does mail doesnt support this.
[/quote]

it isn't asking for any authentications... :( So my ISP must support SMTP... am i right?

Share this post


Link to post
Share on other sites
I saw the warning..
The problem is with the mail server that's why I suggest you to make sure you had it working.  :D

Hmm..
Try changing
SMTP = 192.168.110.30
To
SMTP =  localhost

Btw.. Which mail server you using ?
P.S : hacker is just a nick lolz  ;D

Share this post


Link to post
Share on other sites
[quote author=hackerkts link=topic=99143.msg390431#msg390431 date=1151835428]
I saw the warning..
The problem is with the mail server that's why I suggest you to make sure you had it working.  :D

Hmm..
Try changing
SMTP = 192.168.110.30
To
SMTP =  localhost

Btw.. Which mail server you using ?
P.S : hacker is just a nick lolz  ;D
[/quote]


[mail function]
; For Win32 only.
SMTP = localhost
smtp_port = 25

; For Win32 only.
sendmail_from = info@info.com

still having problem.....

Share this post


Link to post
Share on other sites
what port is your router set to?

what mail server useing?

router must redirect smtp to mail server ip.

smtp=router ip to the mail server.

smtp_port= router smtp port for the mail server.

send_mail_from=mail server for admin like admin@whatevr.com.

Share this post


Link to post
Share on other sites
[quote author=redarrow link=topic=99143.msg390439#msg390439 date=1151836696]
what port is your router set to?

what mail server useing?

router must redirect smtp to mail server ip.

smtp=router ip to the mail server.

smtp_port= router smtp port for the mail server.

send_mail_from=mail server for admin like admin@whatevr.com.
[/quote]

let me collect those informations...

Share this post


Link to post
Share on other sites
i know its all confusing but i do sisco routing from home to business users daily so i no i can help ok
pm the information to me if your worried ok.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.