Jump to content

Archived

This topic is now archived and is closed to further replies.

aluviana

selecting data + wrong ID

Recommended Posts

Hello,

This is the script for retrieving a categorie names from my DB.
It works fine.

[code]
$query  = "SELECT * from categories where parent_id = 0";
$result = mysql_query($query);


          while($row = mysql_fetch_array($result, MYSQL_ASSOC)) {
         
          echo "<ul><li><a href=\"meni_sub.php?id_kat = {$row['id_cat']}\"> {$row['cat_name']}</a></li></ul>";

 
  }

[/code]

Now, some of the categories have their own sub-categories and I want to link the categories to them. For that linking
i am using meni_sub.php:

[code]
$query  = "SELECT cat_name, parent_id from categories where parent_id = '$id_kat'";
$result = mysql_query($query);


          while($row = mysql_fetch_array($result, MYSQL_ASSOC))
          {
         
            echo "<ul><li>{$row['cat_name']}</li></ul>";

 
      }
[/code]

As a result i get the names of all the categories and subcategories in the table, but i need only the subcategorie that is linked to the specific categorie. The problem is in pasting
the ID from the first script to another so the second script knows witch subcategorie to retrieve.

So, what is wrong with this script?

tnx!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.