Jump to content

SitePearl - finished site


Gighalen

Recommended Posts

I posted another thread about my site about a month ago, and have recently revamped my entire site based on the feedback I recieved. I think I finally have it finished, but if you have any more constructive feedback, I'd be more than happy to recieve it.

 

The website is www.sitepearl.com, and it IS 100% operational if you need some cheap/reliable web hosting :)

 

Thanks again,

Tom

Link to post
Share on other sites

First, I would guess that you downloaded a template and modified it?  The site is using tables for markup of the entire page.  The header seems broken, the logo/menu/graphic just seem like they are all out of place. The About Us page has nothing there that is worth dedicating a page to.  The best/cleanest looking page is the support page.

Link to post
Share on other sites

There is a bad CSS request going on. Always check via the css validator.

 

- I concur with jomb's comments. (breakage includes your outer white border 'quitting' midway down the page).

- Navigation issues: When you are on any non-index.php page, clicking on home does nothing (home link points to self current page?) Test, test and test some more. This also tells me that you are not using say an master php include file for the entire top menu to be shared across the site. This means, you make a modification to the menu on one page, you must go through all the other pages and do the same. By using an include file via require(), you can share the same menu across all pages (assuming all pages has the same require path and include file). Makes modifications site wide consistent and very easy to do.

 

 

Link to post
Share on other sites

The header came from a template, the rest of it I designed myself.

 

Please be more specific on how the logo/menu/graphic seem out of place. I have tested it in FF, IE, and Opera and it looks fine.

Link to post
Share on other sites

@alpha

 

- I just added a mod_rewrite function about 30 seconds ago, so you probably just clicked on the link at just the wrong time lol.

 

-I am using a master php file. Yet again, you probably just clicked on a link while I was implementing the mod_rewrite function.

 

-And thanks for the copyright info LOL.

Link to post
Share on other sites

@alpha

 

- I just added a mod_rewrite function about 30 seconds ago, so you probably just clicked on the link at just the wrong time lol.

 

-I am using a master php file. Yet again, you probably just clicked on a link while I was implementing the mod_rewrite function.

 

-And thanks for the copyright info LOL.

 

The navigation problem still persists... (on the support page, clicking on home brings me home.. but not on the other pages). Besides, I don't see this as a mod_rewrite problem.. it deals with how the page lacks shared files for top menus by example.

 

Also, note the breakage of your menu alignment.

This shot is from the Hosting page.. (the support page seems to be the only page that has this problem fixed..) [tested in Firfox 3.0.5 and Opera 9.62]

Link to post
Share on other sites

The small fonts in the upper left hand corner links (home and login) seems to vary in size and whether or not they are underlined it seems.

From home thru Contact, those small upper links render consistently, yet on the Support page, they seem 'smaller' and do not have the underlines...

On Opera, the small graphic image represntations above them have no underlines, yet in Firefox, they do (except for the support page).

small issue to be sure.. but having display consistencies look better.

 

It is far easier to construct one include file that contains the entire top part, coded to behave and work correctly, and have this file shared across all the other pages.. this way, you put out one fire, and all are put out... As it is, you are having to fix multiple display issues across multiple pages. Makes maintanance rather annoying, no?

Link to post
Share on other sites

There are two theme files: One for the billing software, one for the rest of the site.

 

I believe I have fixed all the errors you have mentioned, though. Opera and FF both show the proper alignment of the logo and navigation, and I set both the billing and site theme to run off a single style sheet, so things should be more consistent now.

 

Please correct me if I am wrong.

Link to post
Share on other sites

The header came from a template, the rest of it I designed myself.

 

Please be more specific on how the logo/menu/graphic seem out of place. I have tested it in FF, IE, and Opera and it looks fine.

http://www.templatesbox.com/premium-templates/website-templates/template110.htm

 

thats not designing, all you did is change the body and made it look worse.. =/

sorry i just don't like it when people use templates.

 

 

Link to post
Share on other sites

The header came from a template, the rest of it I designed myself.

 

Please be more specific on how the logo/menu/graphic seem out of place. I have tested it in FF, IE, and Opera and it looks fine.

http://www.templatesbox.com/premium-templates/website-templates/template110.htm

 

thats not designing, all you did is change the body and made it look worse.. =/

sorry i just don't like it when people use templates.

 

 

 

I figured it was...

 

Now I see the original the header is just designed to look out of whack. 

Link to post
Share on other sites

The header came from a template, the rest of it I designed myself.

 

Please be more specific on how the logo/menu/graphic seem out of place. I have tested it in FF, IE, and Opera and it looks fine.

http://www.templatesbox.com/premium-templates/website-templates/template110.htm

 

thats not designing, all you did is change the body and made it look worse.. =/

sorry i just don't like it when people use templates.

 

 

 

I figured it was...

 

Now I see the original the header is just designed to look out of whack. 

 

Actually the original template was all tables, and EVERYTHING had an image for it.

 

I redesigned it using CSS, using only minimal images from the original and using tables only to nestle to main content of the page (The silver containers).

 

There is no code from the original template in this one :P

 

Please be more specific on the layout 'breaking'. I redid the navigation and it looks fine in Opera, FF, and IE.

Link to post
Share on other sites

sorry i just don't like it when people use templates.

 

I personally don't mind if people use them (after all, that's what they're there for). I just wish posters would just come out and say it from the get go. Twice now this happens (that I know of)...

 

As far as I'm concerned, 'the spirit of this forum' is to have people come it with their own creations for comments (the forum title doesn't explicitly state as such.. just something I personally perceive). Just would be nice to mention it is all I'm saying.

I suppose one could counter argue that it's the feedback that is important, not so much as where the site's code originated (assuming it isn't code outright ripped off from someone else that is).

Link to post
Share on other sites

As I said, I wrote the code for the actual site myself, just borrowed design and images from a template.

 

Fixed:

-When a user tries to go to sub-dir not in the include array, a custom error page is displayed instead of a include() error.

-Removed login/home icons from top.

-Fixed some link CSS issues.

-Changed a few padding values.

Link to post
Share on other sites

As I said, I wrote the code for the actual site myself, just borrowed design and images from a template.

 

Fixed:

-When a user tries to go to sub-dir not in the include array, a custom error page is displayed instead of a include() error.

-Removed login/home icons from top.

-Fixed some link CSS issues.

-Changed a few padding values.

oh ic, this is like a coding thing..i gotcha. My bad.

Link to post
Share on other sites
  • 2 weeks later...

First off, the prices aren't all that great :-P My prices are about... half that. But besides that...

 

I really like the colors you chose. The 'Your hosting solution' blends in a bit in the header, so darken that a bit if you can. Other than that, I love it.

 

As for the code, kill the tables. Switch over to divs and use labels for the forms.

 

Best of luck to you and your hosting services :D

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.