Jump to content

Archived

This topic is now archived and is closed to further replies.

jordanwb

URL file-access is disabled in the server configuration

Recommended Posts

When I try to update the currencies on my osCommerce install I get the following error:

 

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 14

 

Warning: file(http://www.oanda.com/convert/fxdaily?value=1&redirected=1&exch=CAD&format=CSV&dest=Get+Table&sel_list=CND) [function.file]: failed to open stream: no suitable wrapper could be found in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 14

 

Warning: implode() [function.implode]: Invalid arguments passed in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 18

 

Warning: file() [function.file]: URL file-access is disabled in the server configuration in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 28

 

Warning: file(http://www.xe.net/ucc/convert.cgi?Amount=1&From=CND&To=CAD) [function.file]: failed to open stream: no suitable wrapper could be found in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 28

 

Warning: implode() [function.implode]: Invalid arguments passed in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php on line 32

 

Warning: Cannot modify header information - headers already sent by (output started at /var/www/localhost/htdocs/oscommerce/admin/includes/functions/localization.php:14) in /var/www/localhost/htdocs/oscommerce/admin/includes/functions/general.php on line 22

 

I'm running php 5.2.8-r2 on Gentoo Linux with Apache 2.2.10

Share this post


Link to post
Share on other sites

Seems you may need to enable allow_url_fopen in your php.ini. It would also however seem to be quite the ridiculous dependency on osCommerce's behalf.

Share this post


Link to post
Share on other sites

Seems you may need to enable allow_url_fopen in your php.ini. It would also however seem to be quite the ridiculous dependency on osCommerce's behalf.

 

It's used for updating currencies. I'm getting other php errors too. I hope that's not a display of the application's quality.

 

I'm no longer getting that error but it seems that "CAD" is not a valid currency code for the Canadian Dollar:

 

Warning: The primary exchange rate server (oanda) failed for Canadian Dollar (CAD) - trying the secondary exchange rate server.

Error Error: The exchange rate for Canadian Dollar (CAD) was not updated via xe. Is it a valid currency code?

Share this post


Link to post
Share on other sites
I hope that's not a display of the application's quality.

 

Ive not used / looked at hit, though I have heard things here and there.

 

What other types of errors are you getting?

Share this post


Link to post
Share on other sites

What other types of errors are you getting?

 

Warning: array_merge() [function.array-merge]: Argument #1 is not an array in /var/www/localhost/htdocs/oscommerce/admin/customers.php on line 733

 

Warning: array_merge() [function.array-merge]: Argument #2 is not an array in /var/www/localhost/htdocs/oscommerce/admin/customers.php on line 735

 

Warning: reset() [function.reset]: Passed variable is not an array or object in /var/www/localhost/htdocs/oscommerce/admin/includes/classes/object_info.php on line 17

 

Warning: Variable passed to each() is not an array or object in /var/www/localhost/htdocs/oscommerce/admin/includes/classes/object_info.php on line 18

 

when I go to /admin/customers.php?selected_box=customers

 

I'll look at ZenCart

 

Yikes, there's a lot of osCommerce hate there.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.