Jump to content


Photo

IIS smtp setting - PHP mail not leaving Queue Folder


  • Please log in to reply
3 replies to this topic

#1 manichean

manichean
  • Members
  • PipPip
  • Member
  • 29 posts

Posted 19 July 2006 - 11:55 AM

Hello,

I would like my default virtual SMTP server to send email using php, when I use the Mail() function in php I get no errors and the NTFS_12868f1001c6ab2700000004.EML(just an example as this changes) file is created and placed into the Queue folder inside my c:\inetpub\mailroot\Queue. It never sends from this folder the email just stays there.

At first I thought it was a php.ini file problem but my settings are 100% correct(as I understand it) let me give you some specs. Currently I think its a relay problem but im just not getting this right  :-\

PHP.INI
SMTP = localhost
smtp_port = 25
sendmail_from = mhodge_txs@yahoo.com

PC SETUP
PHP Version 5.1.3
IIS 5.1
Windows XP SP 2

Default Websites
Right click properties
Server Extensions tab ->  Specifiy how mail should be sent -> Settings button
Web servers mail address : @localhost
Contact Address : @localhost
SMTP mail server: localhost

Default SMTP virtual server settings
Right click properties
IP Addresses: All Assigned
Access Tab -> Connection : All except list below
Access Tab -> Relay : All except list below

telnet localhost 25
220 manimobile Microsoft ESMTP MAIL Service, Version: 6.0.2600.2180 ready at  We
d, 19 Jul 2006 13:48:47 +0200

Please help this is most frustrating
Thanks

#2 manichean

manichean
  • Members
  • PipPip
  • Member
  • 29 posts

Posted 20 July 2006 - 05:30 AM

Anyone else having similat problems ?

#3 redarrow

redarrow
  • Members
  • PipPipPip
  • Advanced Member
  • 7,308 posts
  • Locationlondon

Posted 20 July 2006 - 08:28 AM

Turn your firewall off.
Wish i new all about php DAM i will have to learn
((EMAIL CODE THAT WORKS))
http://simpleforum.ath.cx/mail2.inc
((PAYPAL INTEGRATION THAT WORKS))
http://simpleforum.a...aypal1_info.inc

#4 manichean

manichean
  • Members
  • PipPip
  • Member
  • 29 posts

Posted 20 July 2006 - 11:21 AM

Thanks for the suggestion but still no luck, turning off the firewall did not help, I already had the port (25) open.

This is making me frustrated.....  >:(

Anyone got any other ideas




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users