Jump to content

Archived

This topic is now archived and is closed to further replies.

Buyocat

Enabling mod_userdir in Apache 2 on OS X

Recommended Posts

Hi, I recently installed Apache 2 (locally) and things are almost right... I followed the instructions found http://www.phpmac.com/articles.php?view=244 which were very helpful, but now I would like the ~/Username to point to the /Username/Sites folder.  While the guide offers some explanation on how to do this, and I followed it's instructions, I am getting a "Forbidden you do not have access to /~Username on this site" message when I try to load the page.  Just to be clear I am able to load 127.0.0.1 successfully.  I believe the issue may be due to my httpd.conf and the lack of a <if module> statement for mod_userdir, but I'm not sure how to add everything.  For starters how can I include the module (which doesn't appear to be in my /modules directory), I read on the Apache site that it was a base component and always compiled, so do I even need to LoadModule it?  Currently my httpd.conf has something that looks like this...

[code]Include conf/extra/httpd-userdir.conf[/code]

And my httpd-userdir.conf looks like this:

[code]UserDir Sites

#
# Control access to UserDir directories.  The following is an example
# for a site where these directories are restricted to read-only.
#
<Directory /home/*/Sites>
    AllowOverride FileInfo AuthConfig Limit Indexes
    Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
    <Limit GET POST OPTIONS>
        Order allow,deny
        Allow from all
    </Limit>
    <LimitExcept GET POST OPTIONS>
        Order deny,allow
        Deny from all
    </LimitExcept>
</Directory>
[/code]

Thanks for any help, Buyo

Share this post


Link to post
Share on other sites
I think your going to have to allow from all wich I dont think your doing

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.