Jump to content


Photo

mysql_connect() error


  • Please log in to reply
3 replies to this topic

#1 Redeemer

Redeemer
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 21 July 2006 - 03:39 AM

Warning: mysql_connect(): Client does not support authentication protocol requested by server. Consider upgrading MySQL client in ...... on line 6.


Please help i cant figure this one out i tried upgarding mysql then i tried PHP the a new apache but i cant get it to work... Help please ???

#2 trq

trq
  • Staff Alumni
  • Advanced Member
  • 31,041 posts

Posted 21 July 2006 - 03:50 AM

What versions of both php and mysql are you running?

#3 Redeemer

Redeemer
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 21 July 2006 - 03:56 AM

MySQL  4.1.20 essential
PHP  4.3.11
Im using apache 2.0.55 if that matters



#4 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 21 July 2006 - 10:05 AM

You'll want to use the OLD_PASSWORD directive when setting your password for mysql. Which OS are you running, unix based or windows?

I think you'll better or upgrading PHP to PHP4.4.2




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users