Jump to content

Archived

This topic is now archived and is closed to further replies.

Fearpig

PHP MySQL Set up

Recommended Posts

Hello,
I'm hoping that someone can help me with this  :)
I've installed MySQL and PHP5 using the standard windows install executables and I'm now trying to configure PHP so that MySQL is enabled.

So far I've edited the PHP.ini file as shown below:

;extension=php_mbstring.dll
;extension=php_bz2.dll
;extension=php_curl.dll
;extension=php_dba.dll
;extension=php_dbase.dll
;extension=php_exif.dll
;extension=php_fdf.dll
;extension=php_filepro.dll
;extension=php_gd2.dll
;extension=php_gettext.dll
;extension=php_ifx.dll
;extension=php_imap.dll
;extension=php_interbase.dll
;extension=php_ldap.dll
;extension=php_mcrypt.dll
;extension=php_mhash.dll
;extension=php_mime_magic.dll
;extension=php_ming.dll
extension=php_mssql.dll
extension=php_msql.dll
extension=php_mysql.dll
;extension=php_oci8.dll
;extension=php_openssl.dll
;extension=php_oracle.dll
;extension=php_pgsql.dll
;extension=php_shmop.dll
;extension=php_snmp.dll
;extension=php_sockets.dll
;extension=php_sqlite.dll
;extension=php_sybase_ct.dll
;extension=php_tidy.dll
;extension=php_xmlrpc.dll
;extension=php_xsl.dll

I've enabled three of the extensions.... are they all necessary or have I missed one?
I then rebooted the server but I'm still getting the error message shown below:


Fatal error: Call to undefined function mysql_connect() in D:\Intranet v3\php_telephone_list\index.php on line 8
PHP Warning: PHP Startup: Unable to load dynamic library './php_mssql.dll' - The specified module could not be found. in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library './php_msql.dll' - The specified module could not be found. in Unknown on line 0 PHP Warning: PHP Startup: Unable to load dynamic library './php_mysql.dll' - The specified module could not be found. in Unknown on line 0


The only instructions I can find to help is a line in a PHP3 tutorial saying I have to right-click on php_iis_reg.inf and select install but I can't find the file on my system. Any help will be appreciated as I'm fed up with looking through out-of-date websites!  ;D

Share this post


Link to post
Share on other sites
haaaaaaaaaaaaaaaaaaa

Did you put the mysql_dll in the windows dirctory.

Share this post


Link to post
Share on other sites
Nope.....

Did you mean the libmySQL.dll file from the MySQL Server bin?

Do you know of any good tutorials on the setup of PHP / MySQL?

Thanks for your help Redarrow.

Share this post


Link to post
Share on other sites
this link like having god next to you lol ............

ps. tell me what you think of the link cheers.

when on the site scroll to the bottom and you continue to do all installs ok.

good luck


http://www.webmasterstop.com/48.html

Share this post


Link to post
Share on other sites
Hello again,
The site looks good with good descriptions but it doesn't help me as I'm running IIS and there's nothing on configuring that.  :-[

Can anyone tell me a website with a tutorial detailing how to get MySQL5, PHP5 and IIS6 working together.

Share this post


Link to post
Share on other sites
Sorry Redarrow!

There is a load of stuff on the website you linked!! Just getting frustrated and skipping through stuff....!

Thanks again for your help on this.

Tom.

Share this post


Link to post
Share on other sites
god sent me this  lol

http://www.iis-resources.com/modules/AMS/article.php?storyid=18

Share this post


Link to post
Share on other sites
Right then....  :-\

I've tried following the tutorials which all seem to be for slightly different version of the software compared to mine. I've also reinstalled IIS, PHP and MySQL and I still get the same error. I've gone back to the PHP.ini file and made the following extensions active:

extension=php_mssql.dll
extension=php_msql.dll
extension=php_mysql.dll

However when I search my system I cannot find php_mysql.dll...? I can connect and get data from an Access file via ODBC which shows that php and iis should be working together correctly. I'm running "EMS SQL Manager 2005 for MySQL" which allows me to upload and change the database in MySQL. 

Can anyone tell me where I'm going wrong....... Please help as I'm on the verge of giving up on PHP and using ASP as I want to get on with site designing.

Share this post


Link to post
Share on other sites

; Maximum time (in seconds) for connect timeout. -1 means no limit
mysql.connect_timeout = 60


is yours the same or not?

Share this post


Link to post
Share on other sites
Hello again Redarrow.....

Here's the SQL part of the php.ini file (I took out the comments so you can see more easily).

[MySQL]
mysql.allow_persistent = On
mysql.max_persistent = -1
mysql.max_links = -1
mysql.default_port =
mysql.default_socket =
mysql.default_host =
mysql.default_user =
mysql.default_password =
mysql.connect_timeout = 60
mysql.trace_mode = Off

So it has got the 60 second time-out that you mentioned. It shouldn't be a problem for the database to process as there is only one table in there with 20 records. There will be more records when I know its running. Any other ideas...?

Share this post


Link to post
Share on other sites
I'm running all the latest versions:

MySQL 5.0.21
IIS 6.0
PHP 5.1.4

Could it be the PHP extension for MySQL thats not running properly?

Share this post


Link to post
Share on other sites
Fearpig please download the zipped binaries version for PHP5, now extract the contents of the zip file over your existing PHP directory. As the installer has a few files missing. Now move the libmysql.dll to the C:\WINDOWS folder, or C:\WINNT if the WINDOWS folder doesnt exist.

Also move the php.ini to the same folder too. Make sure you have setup the extension_dir line within the php.ini correctly too. Also if you want to use msql/mssql I think you'll also want to move the msql.dll file too to the same folder as the php.ini.

Whats results do you get now?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.