Jump to content

Archived

This topic is now archived and is closed to further replies.

nilbog

Linux Install not quite working....

Recommended Posts

Great board you guys have here, I have searched around, without luck on this issue, however:

 

I am trying to set up a server with the ultimate goal of running tikiwiki (see tikiwiki.org). I have managed so far to install NetBSD, fluxbox, Apache, and PHP4. This was no small feat, my friends. I\'m pretty darn new to the whole linux thing.

 

Anyway, the last step before installing tiki is to get MySQL working. I downloaded and unpacked the standard package and was following the steps in the \"INSTALL-BINARY\" file. Everything seemed to work fine until I got to the \"chown -R root\" command. That one didn\'t work at all - it just gave me a proper syntax report.

 

I kept going and got to the last command: \"bin/mysqld_safe --user=mysql &\"

Which returns the following:

\"[1] 4270

Smokey# Starting mysqld daemon with databases from /wd1/mysql/data

031229 16:37:57 mysqld ended\"

 

at which point it hangs there until I hit enter, and it returns:

\"[1] Done bin/mysqld_safe --user=mysql\"

 

and returns to the prompt.

 

So it doesnt seem like it should be ending as soon as it starts, eh?

 

Also, shouldn\'t something be installed to where my other www files are? in the tikiwiki instructions it says to setup mysql by going to \"http://mydomain.com/mysql\"

 

I would be eternally gratefull to anyone who could help me or point me in the right direction.

Share this post


Link to post
Share on other sites

Looks like there is another problem - this may be the root of the mess.

When installing the databases \"scripts/mysql_install_db\", I get the following error:

 

ERROR 1033 Incorrect information in files: \'./mysql/db.frm\'

 

I imagine the information would be wrong because the file doesnt seem to exsist.

 

I\'ve searched all over the net and found no solutions.

 

Please help, and I\'ll give you a cookie.

Share this post


Link to post
Share on other sites

All I can suggest is that you look at re-installing mysql again. If the chown command didn\'t work then I would submit that you\'ve missed something, or misunderstood a direction.

 

Some things to check out: Your my.cnf file.

 

Take a look at this and verify that your directories are pointing to where they should be and that permissions are appropriate.

 

For example, does your datadir directory have these permissions:

 

drwxr-xr-x 20 mysql mysql 4096 Dec 30 02:58 mysql

 

I suspect your initial issues with permissions may be the root of your series of problems.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.