Jump to content

[SOLVED] Zend startup project


Recommended Posts


I am trying to create a project with the ZF to get going. To begin with, what I do is very simple. I create a project through the zend command line then I try to connect to the resulting site. Sounds simple right?


My zend library is on /library/webserver/documents/zend (I'm on a mac)

I created a project called test at the same location. Consequently, the base folder for my application is /library/webserver/documents/test.


Now, I'm supposed to be able to point my webserver at that address and see a welcome page. When I go to http://localhost/test/public/ I get absolutely nothing. It's a blank and nothing comes up when I view source. I don't really know what I'm doing wrong at this point. Anyone has a clue what's happening and I can get unstuck?






Link to post
Share on other sites

Also if I replace the index.php file by an index.php with phpinfo(); in it it works fine so it seems to be the content of the current index file that's screwed up. What's funny is I didnt change anything in that file. It's the standard that is created when you create project with ZF.

The current content of the file is below


// Define path to application directory
    || define('APPLICATION_PATH', realpath(dirname(__FILE__) . '/../application'));

// Define application environment
    || define('APPLICATION_ENV', (getenv('APPLICATION_ENV') ? getenv('APPLICATION_ENV') : 'production'));

// Ensure library/ is on include_path
set_include_path(implode(PATH_SEPARATOR, array(
    realpath(APPLICATION_PATH . '/../library'),

/** Zend_Application */
require_once 'Zend/Application.php';  

// Create application, bootstrap, and run
$application = new Zend_Application(
    APPLICATION_PATH . '/configs/application.ini'

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.