Jump to content

Archived

This topic is now archived and is closed to further replies.

rupertthebear

Permissions issues with Apache2.2.3 on Debian 3.1

Recommended Posts

Hi, I have just installed an source installation of Apache2.2.3 on a fresh net install CD image Debian 3.1 distro on my PC (no web server, file server or mail server intalled at that time).

I downloaded to my {desktop}[b]/rupert/local/ [/b] folder, unzipped, untarred and ran [tt][size=12pt]./configure --enable-mods-shared-all[/size][/tt] and changed to my [b]/rupert/local/httpd-2.2.3/[/b] folder.
I ran [tt][size=12pt]make[/size][/tt] and then tried to run [tt][size=12pt]make install[/size][/tt]
I got permission denied messages.
Just for a laugh, I logged in as root and tried it again: Apache was installed to [b]/usr/local/apache2/[/b]
Not to be silly, I logged in as a civillian again and [thru impatience and ignorance] I ignored [b]httpd.conf[/b] and tried [tt][size=12pt]/usr/local/bin/apachectl start[/size][/tt]
I got permission denied messages again.
Logging in as root again, I found that running [tt][size=12pt]/usr/local/bin/apachectl start[/size][/tt] showed no error message - neither did [tt][size=12pt]/usr/local/bin/apachectl stop[/size][/tt]

Please help.  While I could strip everything naked with a bit of chmod-ery, still I'm wondering: what would be the best permissions setup for [b]/usr/local/apache2/[/b] downwards?
Would it be better to delete everything and install Apache somewhere else?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.