Jump to content


Photo

Trouble getting PHP on Apache working properly (403)


  • Please log in to reply
1 reply to this topic

#1 lachesis

lachesis
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 12 August 2006 - 04:41 PM

Apache server: Apache 2.2.3
PHP: 5.1.4
MySQL: 5.0
Platform: Windows XP SP2

Apache will server the default page with an index listing as follows:

Index of /

    * index.php

When I click on index.php, I get:

Forbidden

You don't have permission to access /php/php-cgi.exe/index.php on this server.

Index.php contains the following code:

<?PHP phpinfo(); ?>


These are what i think are the relevant portions of my httpd.conf:
ServerRoot "C:/websrv/"

DocumentRoot "C:/websrv/sitedocs/"
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Order deny,allow
    Deny from all
    Satisfy all
</Directory>

<Directory "C:/websrv/sitedocs/">
Options Indexes FollowSymLinks All
AllowOverride None
Order allow,deny
    Allow from all
</Directory>

ScriptAlias /php/ "C:/websrv/php/"
AddType application/x-httpd-php .php
Action application/x-httpd-php "/php/php-cgi.exe"

I've tried to right click on folder and give access to !USR_Machine but I'm not on a domain so don't have the 'security' tab.

Any ideas?

#2 tomfmason

tomfmason
  • Staff Alumni
  • Advanced Member
  • 1,696 posts
  • Locationstealing your wifi

Posted 13 August 2006 - 02:55 AM

Is this xp home? if so you need to restart in safe mode to be able to set the permissions properly. When you restart in safe mode you will have acess to the security tab.

Traveling East in search of instruction, and West to propagate the knowledge I have had gained.

current projects: pokersource

My Blog | My Pastebin | PHP Validation class | Backtrack linux





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users