Jump to content


Photo

Strange entry shown using phpinfo()


  • Please log in to reply
2 replies to this topic

#1 slongmire

slongmire
  • New Members
  • Pip
  • Newbie
  • 9 posts

Posted 16 August 2006 - 02:20 PM

I have php 4.4.3 runing on WinXP Pro SP2 under IIS 5.1 as an ISAPI installation. When I run phpinfo() in a test web page, I get the standard page generated that shows what parts of php are installed, etc. However, I noticed the strange entry for include_path that points to .;c:\php4\pear below. I have no c:\php4 directory, and never have. Neither have I attempted to install pear.

I exported a couple of sections from the phpinfo() web page so maybe someone can help me troubleshoot and fix this entry.

Directive Local Value Master Value
display_errors Off Off
display_startup_errors Off Off
doc_root c:\inetpub\wwwroot c:\inetpub\wwwroot
docref_ext no value no value
docref_root no value no value
enable_dl On On
error_append_string no value no value
error_log syslog syslog
error_prepend_string no value no value
error_reporting 2047 2047
expose_php On On
extension_dir c:\php\extensions c:\php\extensions
file_uploads On On
gpc_order GPC GPC
include_path .;c:\php4\pear .;c:\php4\pear

In checking the php.ini file, the lines for include_path (both the Unix and the Windows versions) are commented out and not set. In neither of those examples did anything ever point to c:\php4\pear, either.

Thanks,

Steve

#2 wildteen88

wildteen88
  • Staff Alumni
  • Advanced Member
  • 10,482 posts
  • LocationUK, Bournemouth

Posted 16 August 2006 - 02:37 PM

This is normal. These are default values built into PHP itself if no value is set for include_path within the php.ini. I get the same result with PHP5 as an Apache Module. You can define a defualt include path by finding this within the php.ini:
; Windows: "\path1;\path2"
;include_path = ".;c:\php\includes"
Now remove the semi-colon infront of include_path. Now change c:\php\includes to the direcotry in which you want PHP to search in first when including/requireing files

More information can be found over at php.net on this setting


#3 slongmire

slongmire
  • New Members
  • Pip
  • Newbie
  • 9 posts

Posted 16 August 2006 - 05:45 PM

Thanks for the info. I thought I'd messed up again!  ::)




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users